Problems saving via proxy

This discussion was created from comments split from: sites reached with proxy not saving PDFs.
  • edited 7 days ago
    I have the exact same issue since the last couple of days. (Don't know what I changed or updated that started this)

    1. When I'm on a PDF in firefox and click the zotero button to save it, I get the 'X' mark and 'save failed, is zotero running?'

    - I have verified zotero is running
    a. here is the debug ID : D466456604, when I try to reach this URL - https://www-tandfonline-com.ezproxy.rice.edu/doi/pdf/10.1080/00213624.1999.11506190?needAccess=true

    b. Here's another debug ID:D1975787873, when I try to save this URL - https://pubs-acs-org.ezproxy.rice.edu/doi/10.1021/cr100311q

    1b. When I disable proxy redirection in zotero and manually change the URL to remove the proxy, the PDF save works

    2. I have noticed the same issue with saving articles as well, when I go through the proxy, only the embedded metadata is saved (author, title etc.) and the PDF and snapshot are unable to be saved. But the save works properly when I disable the proxy

    Is there any fix to this? Thanks a lot for the help!
  • Could you produce a Debug ID from Zotero?

    1. In the Zotero Help menu, go to Debug Output Logging and select Enable.
    2. Attempt to save https://www-tandfonline-com.ezproxy.rice.edu/doi/pdf/10.1080/00213624.1999.11506190?needAccess=true in Firefox and wait for the save process to finish/fail
    3. Before doing anything else, return to Zotero Help → Debug Output Logging and click Submit Output, which will disable logging and submit the output to zotero.org. A window should pop up containing a Debug ID. Click “Copy to Clipboard” and paste the Debug ID into this forum thread.
  • Hi @adomasven Thanks for the help.

    I did as you told and here's the debug ID from the Zotero standalone - D921703694

  • Your school's proxy server is misconfigured — it's not sending the appropriate intermediate certificate. Send them to this page:

    https://www.zotero.org/support/kb/incomplete_cert_chain

    As explained in the bottom paragraph there, the SSL Labs test result for the proxy server shows that this is a problem.

    Zotero won't be able to download attachments via that proxy server until this is fixed.
  • Thank you! I will try that.
Sign In or Register to comment.