Strange error (report 699630039) with sync

Hi, I've just submitted an error report for a sync error I can't make head or tails of.
Report number is 699630039.

Error occurs persistently on my work desktop (last 24hrs) running Win10, but not on my laptop (also Win10). Happens immediately after sync start, stopping the sync. Error log cites item/attachment folder numbers (e.g. PDW9JYM6) that don't exist on either computer (the lines about removing fields from item types that don't support them).

Anyone have any ideas for fixing this? Reset sync status perhaps? I move between the two computers throughout the day so sync issues can really slow me down.

  • Also, my library is huge (5741 items and 11.6GB) so low-impact workarounds are preferred!
  • edited May 9, 2019
    disk I/O error
    This is a generic error that usually happens if you have your Zotero data directory on a network share or in a cloud storage folder. It could also indicate actual filesystem or disk corruption, but that's rare.

    If you have your data directory in one of those locations, you should move it to your local disk and point Zotero there.
  • Hmmm, that's alarming, because it's already in a local folder. I put it in C:\ProgramData\Zotero to avoid profile sync issues on my work computer (it has been there for over a year).

    Update: moved folder to appdata\local and same error. So I guess there's been a corruption issue?
  • You can check your disk for corruption.

    It could also potentially be security software, though that's usually a different error.
  • Thanks Dan for the advice. FYI does indeed look like data corruption; I copied over the Zotero folder from the laptop and that worked fine. Something strange going on with the original sqlite file I think but no disk errors reported.
Sign In or Register to comment.