Database update failure

After the recent update, my database could not be converted successfully. An error report was apparently automatically submitted, so I assume you know about it already.

I've previously installed the sqlite client to help Dan debug something, so let me know if you want me to run any SQL on my database.

The update wizard appears every time I start Firefox, so I've disabled the Zotero add-on for now. Do you think a fix will be forthcoming shortly? Or, should I revert to an older version? What's the easiest way to find the second-most-recent version?

Did many people have database update errors?
  • Looks like there was a rare situation in which this error could happen. Grab the XPI from the front page again and try again. (Firefox may cache the old XPI, so if it doesn't work, try downloading from another browser and dragging the XPI into Firefox.)
  • Yep the database update worked fine after I did that.

    After the database update was complete, I was offered a link to the 'Changelog'. I clicked the link, and a new tab did open in Firefox, but it was blank.
  • I'm still getting the error. I downloaded in IE7, then dragged the xpi into Zotero. (Is there more to that than literally dragging the file into an open Firefox window?)

    It seemed to install, but I got the same error.
  • While I'm waiting for a solution to the database problem, is there any way to roll back to a previous version?

    I'm dead in the water right at the moment and have some significant projects due. (I know it's beta, but it's been working soooo well! :))

    Any way of getting a previous XPI?

  • arggem: Are you getting the same error or a different one? Did you send an error report for the latest one?

    Whether you can roll back to an earlier one depends what versions of the DB you have a back up of. Check the Zotero data directory in your Firefox profile directory. If you have zotero.sqlite.28.bak, that's from 1.0.0b4.r2, which is still available from You could install the earlier version of Zotero, close Firefox, make a backup of the Zotero data directory, and then replace the zotero.sqlite file with the zotero.sqlite.28.bak file. Higher numbers likely won't work.

    If you try that, be sure to send an error report using Report Errors for the current problem first so that we can fix it.
  • edited April 30, 2007
    No, I had NOT sent an error report from the last time. I just assumed it was the same. I just now sent in a new report.

    My backup is zotero.sqlite.27.bak. Will that work?

    Thanks for your help!

    EDIT: I downloaded 1.0.0b4.r2 from the link you gave me, and all is well. I did NOT have to copy over the .bak file. It installed and ran great. (Is there some reason I'm missing re: copying over the .bak file? Or am I ok as is?)
  • arggem: No, that's fine. If you were upgrading straight from 1.0.0b4.r2 to 1.0.0b4.r5 and got an error during the upgrade, the database would roll back and would be left unchanged, so just reinstalling b4.r2 would work.

    I'll have to investigate the upgrade problem further to see why the updated r5 isn't working for you.
  • All is well now!!! You fixed it. You da man! Thanks.
Sign In or Register to comment.