Restore to Zotero server does not work


I need to restore TO the server, but am told that I need to enter a username and a password in the Settings tab before doing so - despite having entered both. I've tried this on Firefox 3 on Kubuntu 9.04 and Firefox 3.5 on XP, both give me the same error message.

Is there any other way to delete all online content of my library?

  • dnh
    edited July 4, 2009
    I've now managed to delete the online library by deleting everything on one pc, then copied an older (but correct) database to this computer (everything looks fine). But when I then want to sync, Zotero decides to follow the online library (=deletes everything). Restoring either way does still not work... :(
  • anyone... ? :-\
  • Unfortunately the Restore functions will no longer work until the next beta is out, which should be today or tomorrow. Sorry for the inconvenience.

    You can simulate a "Restore to Zotero server" in the meantime with the following steps:

    1) Turn off auto-sync in Zotero's sync preferences.

    2) Go to about:config in the Firefox address bar, right-click on any line in the list, New, Boolean. Name the new preference "extensions.zotero.sync.debugMenu" and set it to "true". Close Firefox.

    3) Copy in your older, correct database and restart Firefox.

    4) Under Zotero's gear menu, you should see a few new options under "Sync Debugging". Choose "Clear Server Data".

    5) Click the green sync icon. Zotero should sync your local library with the server.

    You can return to about:config and set extensions.zotero.sync.debugMenu to false to hide the menu options.
  • Thanks, Dan, I will give it a try! Why not always have these extra buttons there, they're useful! :)
  • How about restoring from the server?
  • edited July 5, 2009
    Close Firefox, delete (or, better yet, move out of the way) zotero.sqlite and the 'storage' directory within your Zotero data directory, and restart Firefox.
  • Dan,

    This worked. Everything synched from the Zotero server, but (after the initial synch) upon further attempts to synch I am getting an error that reads: "Source item for keyed source doesn't exist in Zotero.Item.getSource()"

    Sent the problem. ID: 1107313289
  • mdobe: That error should be fixed in 2.0b6, available now. The reset options should work again as well.
  • I upgraded to 2.0b6 and my synch works now. Have not needed to try the reset yet, but am glad to know that it works now.
Sign In or Register to comment.