Whenever I try to insert citation in word document using Zotero plugin, a window says, 'THE CITATION STYLE COULD NOT BE FOUND'.

When I click 'OK' the 'ZOTERO - DOCUMENT PREFERENCES' window opens, but the 'CITATION STYLE' box is empty!!!

  • Did it previously worked? Do you see the style in Zotero? (Edit -> Preferences -> Cite) Did you change the Data Directory Location in Zotero?
  • It was citing right until about 2 days ago it began this stubborn attitude!!! Excuse my language!
  • I have just opened the 'Edit -> Preferences -> Cite' and the 'Style Manager' box is empty!
  • And I don't understand what you mean by, 'Data Directory Location in Zotero'?
  • edited April 22, 2019
    1. Edit -> Preferences -> Advanced -> Files and Folders. But I guess you didn't change the location, as you still see your library with all items.

    2. Did you simply try to get the style again (Edit -> Preferences -> Cite -> Get additional styles...) or does it fail?
  • I still see my library with all items.

    I 'Edit -> Preferences -> Cite -> Get additional styles...' and I'm seeing long list of 'Style repository'.
  • What do I do then?!
  • Click on one of the links in that list and see if it adds it to the (currently empty) list of styles.
  • If the list is empty, there's some other problem, so trying to reinstall a single style isn't a good idea. @donnie-yen, try just resetting styles from the Advanced → Files and Folders pane of the Zotero preferences. If that doesn't work, provide a Debug ID for Zotero startup using the "Restart with Logging Enabled…" option.
  • It added APA style!
  • OK, but see my message above. You should just reset styles so that you have all the default styles.
  • Does this mean I have to be selecting one-by-one of them, to recover them into the 'Style Manager'?
  • No, just reset styles as I say above.
  • @donnie-yen please follow dstillman requirement. Losing all styles is not normal behavior.
  • I noticed that when I tried to select
    'American Psychological Association 6th edition(2019-04-11 21:28:27)',

    It gave error,
    '...occured while installing "thhps://www........./apa" '

    But when i tried
    'American Psychological Association 6th edition ("doi:" DOI prefix)(2019-04-11 21:31:47)'

    It worked!
  • Okay poettli.
  • dstillman,

    When I clicked 'Reset Styles', it gave a warning,

    'Any new or modified styles will be lost.'

    Does that mean it will change all the citations I have done in all my word files?!!!
  • poettli and dstillman,

    I really thank you for this tremendous effort to get me back from that brink of disaster!!!

  • Does that mean it will change all the citations I have done in all my word files?
  • Hi,

    I have a similar situation, but only one style disappear from the style pane (a style I created). But the style is present in the Zotero Styles folder.

    So, I got the same message as donnie-yen :


    I tried other style and all work fine ! I created another, and that one didn't disappear.

    Thanks for the help,

  • I read other messages and I check my style ID, which I never change for years, and here the ID:

    Chicago Manual of Style 17th edition (note) Sopromet - 2

  • OK I found the culprit.

    I modified a small bit of my csl code (not the ID) and the file was not anymore compliant.


  • When you are editing a CSL style, it’s a good idea to check it using
Sign In or Register to comment.