Zotero not working with documents on onedrive

When I am working on a document stored on my onedrive folder zotero will not open.

Zotero experienced an error updating your document.

Would you like to view troubleshooting instructions?

I tried all of the troubleshooting steps and none worked. If I save the same document outside of onedrive folder then the problem goes away.
  • Could you produce a Debug ID from Zotero?

    1. In the Help menu, go to Debug Output Logging and select Enable.
    2. Attempt to insert a citation in a document saved in One Drive. Make sure you do not have any other documents open.
    3. Before doing anything else, return to Help → Debug Output Logging and click Submit Output, which will disable logging and submit the output to zotero.org. A window should pop up containing a Debug ID. Click “Copy to Clipboard” and paste the Debug ID into this forum thread.
  • For some reason after posting this I had no problems until yesterday when I worked on my file on my laptop and then tried to work on it on desktop.

    Here is the error report:1381225446

    [JavaScript Error: "This command is not available because no document is open. [getDocument:d:\users\build\cygwin\home\build\zotero-word-for-windows-integration\build\zoterowinwordintegration\document.cpp]"]

    version => 5.0.66, platform => Win32, oscpu => Windows NT 6.1; WOW64, locale => en-US, appName => Zotero, appVersion => 5.0.66, extensions => Zotero LibreOffice Integration (5.0.14.SA.5.0.66, extension), Zotero Word for Windows Integration (5.0.12.SA.5.0.66, extension), Shockwave Flash (32.0.0.171, plugin)
  • That's a Report ID. For this we'd want a Debug ID, using the instructions that Adomas provides.
  • Ah sorry, this is it: D2003438147
  • Integration: Instantiating @zotero.org/Zotero/integration/application?agent=WinWord;1 for command addEditCitation with doc C:\Users\[…]\Documents\[…].docx
    That document doesn't appear to be in OneDrive, and I also don't see an error — it looks like the document was successfully updated. Was this meant to be debug output for 1) working with a file in OneDrive and 2) getting the error you reported above?

    (There's also a sync running in the background. If you provide another Debug ID, be sure to wait 15 seconds after adding or editing any items so that auto-sync has had a chance to finish.)
  • edited February 3, 2020
    Just had the same issue. It was working with OneDrive/SharePoint just fine for maybe two weeks before breaking. Now it gives me that "error updating" every time I try to add/edit citation or refresh bibliography for any document on OneDrive/SharePoint. Turning off OneDrive sync makes Zotero work fine (but sadly doesn't work for me because I need to be doing live revisions with a coauthor.) Debug ID: D1361979594
  • The same problem to me, It was strange, I can use it with my word file in onedrive before, Now it gave me a error when I updated the citation as long as the word file in the onedrive. Only if I moved the word file to local file path would zotero work again
  • I had the same problem.
    I paused the OneDrive sync for the duration of time I was working on the document and Zotero started working again. In the absence of a better solution, I will make do with this.
  • I was working on a very long document stored in onedrive a while ago. The worst thing about it was being intermittent. I decided to swap this file over to dropbox to that gave me no hassles. I popped in here today to see if there was still an issue with zotero/onedrive and it seems there is...
  • I have definitely had issues previously but just wanted to report that we've created multiple documents recently on OneDrive, with Zotero and some fast and furious collaboration at times, and did not have any drama. A couple of times I got an error message, but closing and restarting the document fixed it. But I agree with the previous poster that it's a OneDrive issue - I use OneDrive for work but the sync has always been more problematic than with Dropbox.
  • Have teh same issue. My Debug ID is: D1881809921. Any insight?
  • edited 12 days ago
    I have had the same problem. Scared the living daylights out of me the first time, though: my reference list at this point has over 400 items, and hundreds more Zotero citations throughout the document. I couldn't imagine needing to recreate all of those citations. However, I eventually discovered that if I exit and restart Word and then reopen the file, it will begin working again. I guess restarting Word resets whatever interaction with OneDrive needed to make Zotero happy again.
Sign In or Register to comment.