Micorosoft Word (Mac) SpellCheck disabled After Zotero 2.0 Install

Hey Everyone,

I just downloaded zotero yesterday. Already I am using it like crazy. Since I have downloaded, I have noticed that spellchecks are not showing up on my paper. I went to Tools --> Language and noticed that "Do not Check Spelling and Grammar" was checked. I thought "okay, easy fix". However, whenever I turned it off, I went back and noticed it was clicked. I can't turn it off when my cursor is in a paragraph that has used zotero. When I move it to a paragraph that doesn't (ie - intro, summary), i can turn it off. Whenever I move my cursor back to zotero, spellcheck is turned off for the whole document.

Zotero is so convenient, I wouldn't even mind if I had to manually run spellcheck, but now it's not even picking up things. Any help?? I recommended zotero to my boss and she sent it out to the other grad research assistants and I'm supposed to be demoing it during our meeting tomorrow. I really don't want to have to cancel it because of this error.

Thanks everyone!
  • edited July 2, 2009
    Glad to hear your excited about Zotero! I can assure you that the issue you are experiencing is not widespread. Many of the Zotero's hundreds of thousands of users use the Word plugin for their research and teaching.

    I can't replicate the error. Are you using Word 2004 or 2008, and which version of the plugin are you using? Also, are you running any other Word plugins?
  • Tjowens,

    thanks for your response. When I first posted, I was using the latest version of Word on Mac OS X on Leopard.

    Mac OS X - Leopard
    Word 2008
    Zotero v 2

    This morning I came to work and tried it on the following and had the same problem:

    Windows XP
    Word 2007
    Zotero v2

    I also tried copying and pasting into a new word doc (incase the one i was working on was corrupt), but still had the same problem.

    Any help you could offer would be much appreciated.
  • Rather than copy/paste, what happens when you write + cite something from scratch?

    Also: does word display the same language for paragraphs with citations in them as it does for paragraphs with no citations?
  • Noksagt,

    Thanks for your reply. The problem actually started when I would write + cite something in Word. I tried to do the copy/paste as a workaround.

    I also tried doing a workaround. I took off all the formatting through word and everything seemed to work find. However, once I started adding in citations again, the problem reoccured. Once again, I couldn't turn off the "Don't Spell Check" option in Word. I eventually had to remove the Word plugin and re-install the servicepack 2 for Microsoft Office.

    If you guys know of a fix, I would really appreciate it.
  • Hi guys,

    I am actually experiencing the inverse issue since I went to Zotero 2.0. I always have spell check turned off in Word because I use too many words/authors that the spellcheck doesn't recognize. However, when I insert a citation via Zotero, the spellcheck gets turned on for that citation. So every author I insert gets a red line under it, and I have to manually remove it. I can turn off the spellcheck, but with the next citation the spellcheck will have turned back on for that citation. I have searched the forums and the zotero preferences but cannot find a way to turn off the spellcheck. Is there a way around this?


This discussion has been closed.