'dateAdded' cannot be modified for existing items

Hi,

I added some new (duplicated) items today then merged the duplicates. After that I had this error: "'dateAdded' cannot be modified for existing items"
Report ID: 738123554

What can I do to fix it?

Thank you!

P.S: Zotero 5.0.66 on Windows 10 Pro
  • I'm using ZotFile and pcloud WebDAV too
  • I had the same error in Jurism yesterday, in a shared library synced to zotero.org. I assumed that it was a bug in my own code, but it looks like something may be up with merges in the latest Zotero release.
  • edited 10 days ago
    @mscmilan or @fbennett: Can you provide steps to reproduce that? This would definitely be a regression in the latest version, where we changed it to preserve the earliest Date Added, but merging is working for me.
  • @dstillman I had few journal papers that I added few years ago which didn't have any attached PDF because I added them on my home network. Today, I used a different laptop and add them again at my university to get the PDF downloaded as well. Those PDF were renamed by ZotFile and uploaded to pcloud.com WebDAV I believe. Then I went ahead merging the duplicates (choosing the most recent versions of course). After that I had that error when attempting syncing
  • I've just tried that again. Same error 1049744420
  • OK, so this was a sync error, not something you were getting during the actual merge. Should be fixed now. Thanks for reporting.
  • Thanks! I wasn't able to reproduce it immediately. Great to know it's squashed.
Sign In or Register to comment.