Changing format of date field

Hello everybody,

I am having a bit of trouble with the date format of documents. I am stuck with "m d y" when I would like to have "d m y". What I am talking about is neither the "date added" or "modified" fields, but the general "date" which every Zotero item has.

Thi screenshot should show what I mean.
https://i.ibb.co/MccVZxf/screen1.jpg
One can actually see that the "accessed", "date added" and "modified" fields all show the right formatting.

I have read the forums and found two promising threads. However, they did not solve my problem. I link them here as a reference.
https://forums.zotero.org/discussion/6797/zotero-appearance-how-do-i-change-date-format-in-date-added
https://forums.zotero.org/discussion/67032/change-date-format-in-zotero-5

The locale of my pc is set to the United Kingdom.
I changed the general.useragent.locale to "en-GB" and the intl.locale.matchOS to false.
https://i.ibb.co/j45Nyzv/screen2.jpg

Entering "new Date().toLocaleDateString()" in Firefox's Web Console gives me a "m d y" which is consistent with the problem I have in Zotero. I am not sure whether this is relevant or the link between these two problems only existed when Zotero wasn't standalone.

Any ideas on what to do?
  • I thought this problem would be more common...
  • Locale handling has changed since most of the posts in those threads, and it looks like we've lost proper date handling when the locale is set to en-GB. I've added a proper en-GB locale in the latest Zotero beta, so if you install that (or wait for 5.0.57) you should see an "English (UK)" option in the Language menu in the Advanced pane of the preferences and Zotero should properly parse ambiguous dates as d/m/y.
  • @dstillman
    I installed the beta and I confirm the format problem has been solved!
    Thanks a lot for the quick fix.
Sign In or Register to comment.