Chicago 17th (full note): Erroneous Title Capitalization

edited April 7, 2019
This stock style produces incorrect automatic capitalization in title in the case of "et al." E. g.:

Loren Martin and Robert Gerlai, “Sentience: All or None or Matter of Degree? Commentary on Sneddon et Al. on Sentience Denial,” Animal Sentience 3, no. 21 (2018): 5.

Should this be fixed? Is there a way to overwrite this?

I can easily create a version of style without title capitalization but this strikes me as poor practice for major styles.

Thanks for the advice.
  • I can easily create a version of style without title capitalization but this strikes me as poor practice for major styles.
    Fear not. I will add the word "al" to the list of non-capitalizing terms.
  • “al.” Should potentially be added to the list of stop words for capitalization. For now, you can override they capitalization by wrapping “al.” in <span class="nocase"> </span> tags.
  • The deed is done. The change will come out in a future release of Zotero.
  • Thanks both.

    But should it not indeed be "al." rather than "al" or even "et al."? More precise and future readers of code will understand the inclusion more intuitively. A non-capitalized "al" in the title of an article would be offensive to the memory of a certain American gangster, for instance.

    Nice to know how to override capitalization for similar rare cases.
  • I think it's pretty safe to escape al across the board. Al Capone , as a proper name, would always be entered capitalized and so wouldn't get touched in the first place.
  • edited April 8, 2019
    As adamsmith says. Punctuation (and HTML-like tags, and quotes, and maybe other stuff) is removed from the string before capitalization rules are applied, so restricting the rule to "al." isn't really an option. But it's a safe fix, and will prevent unwanted capitalization in names like al-Khwarizmi to boot.
  • Thanks for reporting this!
  • I am having trouble with this using Chicago style with my German citations. Not every word should be capitalized, and this was not a problem until the last two weeks. Now every German word in the titles of my footnotes are being capitalized, which is not grammatically correct for German. I must use Chicago style. What are my options?

    The title casing in Zotero's Chicago Manual implementation has not changed for years, so not sure why you didn't see this earlier.
  • Thank you for your quick help. The difference may be that I have gotten sloppy and not always filled in the language field as I approach the completion of my dissertation, although I have been typing "German" rather than "de."
  • Anything that doesn't start with en will work, though I'd recommend de to ensure future language-related features will work (e.g. if you'd want terms to be localized by the language of the work or the bibliography sorted by languages -- not currently possible, but likely to happen)
  • edited October 21, 2019
    I have some generall problems with capitalization as well. Is there an equivalent of <span class="nocase"> </span> tags for forcing capitalization? 'Near' seems to be on an execption list for capitalization but in some cases (e.g. 'Near-Edge X-Ray Spectroscopy) it should be capitalized.
    Also is there an easier tag for this? Comparable to <sub> and <sup> something like <lower> and <upper> would be more handy to use in my oppinon.


    Easy fix is of course to just write 'Near' so with capital N in the title, then its untouched by the algorithm.
    Nevertheless, I would find <lower> and <upper> handy.
  • @fbennett as per Chicago Manual (8.161 ) the first part of a hyphenated compound should _always_ be capitalized.

    Is there a way to address that in citeproc, i.e. not apply the skip-list?

    (@JackTheMiller -- answer to your questions is no, I'm afraid. We'd definitely not do lower/upper, as that's not valid HTML.)
  • I just found this thread looking for how to change the capitalization of titles in different languages, and I just want to say that the info/link provided by adamsmith on 3 June is so helpful. I had no idea that filling out the language field would make correctly capitalized citations according to the rules of the stated language. Such an awesome function for those of us who work in more than 1 language. Thank you!
  • @adamsmith I'll take a look at this one soon.
Sign In or Register to comment.