Zotero issue with Google Docs

See link to video below.

It has worked effectively in the past


Many thanks for any assistance offered.
  • Have you tried refreshing the page?
  • Many times. Have also uninstalled and reinstalled extension
  • Is there a link to a page, or a text with a link at the start of the document? Could you try removing it temporarily and refreshing? Otherwise, could you place the cursor in an existing link in a document, editing it with Google Docs, and then placing the cursor in a different location to try to insert a citation?
  • I can't get Zotero to work at all with Google docs.

    When I try to insert a citation I get a dialog box that says.. "Zotero is updating your document. Please wait"

    This box never goes away.

    Alternatively I can hover over the Zotero Icon in the toolbar at the bottom of my screen and this shows the red bar into which I can put a citation. So I do that and hit 'return'.... and then...nothing.

    I don't believe I have any conflicting extensions installed....

    Any suggestions.. This thing is definitely not working..
  • Restart your browser and Zotero, try inserting a citation in a new document and confirm whether it works or not.
  • I also have a problem with Google Docs and Zotero. When I click the Zotero Insert citation option, nothing happens. I tried this both in Chrome and Firefox. My Debug ID is: D1884694648
  • Zotero Add-on for Google Docs, not listed on Add-ons list.
  • Zotero Add-on for Google Docs, not listed on Add-ons list.
    sorry, you'd need to say more about what you're referring to. If you're looking at the add-ons in Zotero, it wouldn't show up there. It comes bundled with the connector (where you can disable it).
  • I have the Zotero Connector in my browser, and a separate Zotero tab in Google Docs. The buttons for Zotero are active. But as soon as I click the Add/Edit Citation button, nothing happens or I get the message:
    Zotero is updating your document. Please wait... And I have to wait endlessly.
  • @noorbreuning Restart your browser and Zotero. After clicking any of the Zotero options in Google Docs and getting the "Please wait..." screen check through Zotero windows if a citation dialog popped up. On some OSes minimizing Zotero before working with the browser might cause the Zotero dialogs to not show up on top of other windows.
  • I think this is a systemic bug. I have no idea how to fix this at all, and none of the advice on this forum helps.
  • [JavaScript Error: "TypeError: Cannot read property '9' of undefined
    at Object.injectScripts (chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/background.js:328:45)
    at chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/background.js:267:36"]

    [JavaScript Error: "No frame with id 32 in tab 2."]

    [JavaScript Error: "Cannot access contents of url "chrome-search://most-visited/single.html?title=Most%20visited&removeTooltip=Don%27t%20show%20on%20this%20page&enableCustomLinks=1&addLink=Add%20shortcut&addLinkTooltip=Add%20shortcut&editLinkTooltip=Edit%20shortcut". Extension manifest must request permission to access this host."]

    [JavaScript Error: "Cannot access contents of url "chrome-search://most-visited/single.html?title=Most%20visited&removeTooltip=Don%27t%20show%20on%20this%20page&enableCustomLinks=1&addLink=Add%20shortcut&addLinkTooltip=Add%20shortcut&editLinkTooltip=Edit%20shortcut". Extension manifest must request permission to access this host."]
  • I have the same issue. Stuck on "Zotero is updating your document.
    Please wait…" I have added exclusion for Zotero on Firewall, verified network-proxy-type= 5, nothing.
  • @ymleon: See Adomas's advice above. If you've restarted both your browser and Zotero and also looked for the citation dialog behind other windows, can you Zotero again and provide a Debug ID from Zotero (not the Zotero Connector) for this happening?
  • I think I found a fix! I was having the same problem, but just got it to work. When you restart Zotero, find the citation dialog window that pops up. Pick your citation, but then before you exit, there is a little checkbox at the bottom left that says something about Automatic updates. It says that checking that box can slow things down so I wondered if that was the problem. I "unchecked" it, pressed ok, and immediately Zotero started processing. I was then able to add the author's name, it searched it, and entered the citation. I hope it works for you too!!
  • @ymleon @morryc @paulmacdonnell @noorbreuning
    Please see my comment above. I hope it works for you!
Sign In or Register to comment.