handling page numbers that are hyphenated

I have a report which in which the page numbers are not 1, 2, 3, 4 but 4-1, 4-2, 4-3, etc... When I enter 4-1 Zotero is formatting it as if it is a page range instead of a single page. How can I get Zotero to format it as if it was a single page.
  • How about something like 4\-1-4\-5?
  • No once I put the dash it automatically goes to pp instead of p. I am using a colon instead of the hyphen and it does not treat 4:1 as multiple pages. if I go 4:1-4:17 it does.

    Wonder if this is something to have the development team look at, since many reports and texts have this (especially LARGE-HUGE documents)
  • edited March 20, 2019
    I see, it wasn't clear from your first message the format you where referring to. What is the style you are using?
  • Chicago/Turbian
  • I don't see how we'd be able to do this with reasonable effort without breaking other things.
  • @adamsmith the way that @Poettli recommended by escaping the dash looks to be an easy way and would be a simple conditional statements in the logic.
  • Backslash-escape to preserve a hyphen, and treat the joined numbers as a single alphabetic unit for pluralization purposes should already be working, according to this processor test. The third case in the test looks pretty unreadable to me, but if it's the desired output, the processor should produce it.
  • edited 9 days ago
    From my understanding of this thread Zotero does not support this. Zotero really needs this option - in my view it is bad design not to consider such cases. There are, e.g., proceedings which have the paper number and session separated by a dash (for instance, 3rd paper in the 1st session is encoded as 1-3). As it is customary to use the paper number in the page numbers, one needs to write in the pages field (here, I give 10 pages to our hypothetical manuscript): pages = {1-3:1--1-3:10}. I have many papers like this from different fields for which I need to manually edit the exported .bib file.

    Zotero would need some injection options in the different .bib fields (similar to https://www.zotero.org/support/kb/rich_text_bibliography ). For example, I spent hours today trying to force a capital letter in "3D" for various titles without any success. The 'Title Case' option simply disregards "3D" and forgets to place any curly braces around such term (for unknown reasons). Having an injection method would help so much. Naturally, such methods could open a backdoor to security risks.
  • At least in citations generated by Zotero, the above post by fbennett suggests that backslash escaping works. Can't guarantee that it'll work in bibtex export, though:
    since this has literally been asked about twice in 10+ years, it's not like anyone has spent much time thinking about design for or adding support for it.

    You can post-process bibtex export using the BetterBibTeX add-on, though, so that might well give you what you need.
    You can likely also convince its developer to add support for the backslash escaping if it doesn't work already.
  • Thanks adamsmith for your reply! The \ escaping does not seem to work for the page numbers field - it gets replaced by "\textbackslash".

    I've also just tried BetterBibTex and it actually makes things worse (the "-" are all "-" instead of "--" which I would need to change in thousands of entries).

    I'll try my luck with the devs.
  • I'll be happy to give it a look when an issue is opened on the BBT tracker.
Sign In or Register to comment.