Automatic tags turned themselves on

On my Zotero standalone (latest version, 5.0.60) I've always had the automatic tags option off and only ever used self-defined tags.

Today, as I was typing into the tags field to find a tag, I noticed tons of automatic tags appearing in grey (since none of them are applied). No idea how they got here, and if I choose "delete automatic tags in this library", Zotero asks me if I'm sure I want to delete all 2 automatic tags (even though there are many more of them).

How can I get rid of this feature? Thanks!
  • This may be a bug, but the most common way unwanted tags are imported with the preference off is by importing metadata formats (like RIS etc.). Keywords in such files are not treated as "automatic" for import purposes.
  • I only import papers so I don't think I imported any such formats. Anyway, I see the auto tags are gone now that I've let Zotero update just now (that was FAST btw!).

    Thanks again
  • @adamsmith, Just to let you know that this problem still exists when typing into the "add tag" text fields - there, automatically added tags (that I never applied, and which don't appear in my list of tags) are suggested.
  • edited 11 days ago
    I'm not really sure what you mean here. When you're in the library root, all tags will show up in the tag selector, unless you have it set to now show automatic tags in the tag selector menu. Searching in that box only filters the tags that are already appearing. If it says there are only 2 automatic tags to delete, there are only 2 automatic tags in that library.

    In autocomplete when you're adding a tag, it's possible for tags to appear for a short period of time after they've been removed from all items, but that's it.

    There were recent changes to the tag selector that could have introduced some sort of bug, but the tags have to be from somewhere. Is it possible you're seeing tags from another of your libraries?
  • The tags that appear in the selector are the auto tags that I was seeing a few days ago, and that disappeared from the tag list after adamsmith released the update, after the post above. I don't know enough about the inner workings of Zotero to know where these auto tags come from. Also, I only have one library.
  • edited 11 days ago
    (adamsmith doesn't release updates, and no updates were put out to address this, though 5.0.61 contained low-level changes to the tag selector code.)

    I'm still not understanding what you're describing, so if you can provide more information and/or upload a screenshot and provide a link (or email it to support@zotero.org with a link to this thread), that would be helpful.
  • edited 11 days ago
    To be clear, though, there's a setting in the tag selector that lets you show or hide automatic tags.

    There's another setting — Display All Tags in This Library — that determines whether tags that aren't linked to items in the current view (e.g., a collection) are shown in gray.
  • Another point of clarification: you're aware that there are two options related to automatic tags? There's the option of whether to save them in the preferences, and there's the option of whether to display them in the tag selector menu.
  • But in any case, if it says there are only two automatic tags to delete, you don't have any other automatic tags in your library, so you're describing something else.
  • OK, will submit screenshots viaemail as you suggest - thanks a lot for your help.
  • The tags shown in your email are manual tags on an item in your trash. They don't appear in the tag selector because they're not associated with items in the library root. They appear in tag autocomplete because they're still in your database.

    If you can remember how you added that item to your database we might be able to tell you where the tags came from.
Sign In or Register to comment.