LibreOffice and Zotero extension - problem and solution

First the short version:

The problem: It seems that if the Zotero extension is installed from new in LibreOffice 6.x then the automatic integration does not work.

The solution: In LibreOffice, open Tools > Extension Manager. Click "Add" and find the extension (Zotero_OpenOffice_Integration.oxt) in the Zotero directory:
C:\Program Files (x86)\Zotero\extensions\\install
Open the extension, wait for it to install, and then restart LibreOffice. If the Zotero toolbar is not visible in LO Writer then activate it under View > Toolbars

Then a description with a bit more details:

Recently, I had to install both Zotero and LibreOffice from scratch. Both installations went fine, but until today I have been unable to get the integration to work, i.e. to get the Zotero extension recognized in LibreOffice. No error messages, simply no Zotero toolbar in LO. I tried with LibreOffice 6.1 and 6.2 (the two currently supported versions of LO), with equal results.

Given that the installation has earlier been easy - with earlier versions of LO - I suspect that the problem could be some change when LO changed to version 6. Of course, it could as well be some change in Zotero, but Zotero has not undergone major version change in the this period. Whereever the change lies, the chance of a fix is most likely to originate from the side experiencing the problem, i.e. from the Zotero automatic installation...
I am using Zotero 5.0.60 on Win10, and as mentioned, LO 6.1 or 6.2.

There has been not problem on my laptop CONTINUING Zotero integration from 5.x to 6.x, the problem seems only to relate to a NEW installation of the Zotero integration.

Today, I have found the above solution. I hope it can help others.

Best regards,
  • Thanks, but note that it's best to just report the problem you're having yourself without suggesting it's a general problem. Installation of the LO extension with a clean install of LO works for me on both macOS and Windows, and we'd likely have many more reports of this if it wasn't working for anyone without manual installation.

    You do need an up-to-date Java Runtime Environment (JRE) installed, and without that it will fail (and, for me, fails without a particularly clear error, which we'll look into). But when that's the case simply adding the extension from the .oxt from the Extension Manager as you describe wouldn't work either. With a JRE installed, the installation goes through successfully for me.

    Is it possible you installed the JRE between tests?
  • Okay, I see the problem of many reports. As for JRE, I was aware of that and a JRE was installed and connected with LO from an early point. So I am sure that a missing JRE was not the cause in my case.
  • Don't be so certain about the JRE. You need the proper version (up-to-date) and it must be associated with your LO. That the JRE was once connected to LO doesn't mean that the two were not somehow disconnected. Go through the steps to verify that LO is associated with your JRE.
  • Yes, JRE was up-to-date (version 8 update 201), was installed, and was recognized by LibreOffice.
    But to test again, I have just tried to make a reasonably clean case by uninstalling the Zotero connector first in LO through Extension Manager, and then also telling Zotero that the connector should be uninstalled. Naturally, the Zotero toolbar was then missing.
    Again, (re)installing the connector did not work from Zotero, but did work when I performed a manual installation through Extension Manager in LO, i.e. repeated my workaround.

    I might be the only person having this problem with LO 6 then good, and in that case I am glad I found a solution - good. If I am NOT the only person and my workaround can help others then also good.
Sign In or Register to comment.