Sub-collection folder disappeared

Hi,

I realized around January, 21st that one of my sub-collection folders had disappeared. I had been adding references on the 16th I think, so it disappeared at some point between the 16th and the 21st I believe. There was a lot of references and notes in it. Is there a way to get it back ? Can you explain why it disappeared ?

Many thanks for your answer,
Cheers
  • It may just be somewhere else in your collection hierarchy — a few people have recently reported having collections move by accident, though we're still investigating. Click a collection and press + to expand all collections, and then either look through all the collections or quickly type the name of the collection you're looking for to search for it. You can also look for an item in the library root that was in the collection and highlight the collections it's in.

    If you don't see it, you likely deleted it by mistake, in which case your only option would be to restore from a backup. (If you did delete it by mistake, the items are likely still present in your library.)
  • I have a similar problem. I had a subfolder that I wanted to turn into a main-level folder so that I could access it more easily as I worked from it. So I tried to drag it up to the main level yesterday and nothing happened. I continued using it as a subfolder throughout the day. Today the subfolder is gone. The items in the collection do still exist, but they are "at large" and unorganized and there is no way for me to reconstruct the collection from memory. When I try to trace an article I know was in the original subfolder back to the collections that it is in (Ctrl on a Mac), nothing happens. Clearly the subfolder is gone. Hope this helps Zotero resolve the issue. I will look into restoring from backup.
  • edited 10 days ago
    @caitlin.m.ryan: Would you mind sharing the name of the collection, either here or in an email to support@zotero.org with a link to this thread?

    Also, check your database integrity from the Advanced → Files and Folders pane of the Zotero preferences.
  • Thanks for your response. I replied by email.
  • OK, the collection mentioned in your email still exists online, as a top-level collection, and still has many items in it. You should be able to see it in your online library. If it's not appearing locally, I'd guess that's due to problems with your local database.
    I do get an error when I run the Database integrity check - screenshot attached. Should I follow up with the instructions to use the database repair tool?
    Yes, you should.
  • Very strange. The problem fixed itself, it seems. I located the collection in my online library and now I also see it in my local library too. Full of items including the most recently added ones.

    I am unable to run the repair because my zotero.sqlite.zip file is 135 mb (there is a 100mb limit).
Sign In or Register to comment.