Institutional Author won't sort correctly

edited February 18, 2019
I am working with the APA6 citation style and the institutional author "Open Science Collaboration" is constantly being sorted as though it were "Collaboration, Open Science".

This only happens with an example where there is a co-author:

Open Science Collaboration, & Kappes, H. B. (2014). The Reproducibility Project: a model of large-scale collaboration for empirical research on reproducibility. In F. Leisch & R. D. Peng (Eds.), Implementing Reproducible Research (pp. 299–324). New York, USA: CRC Press, Taylor & Francis Group.

As I said the citation above is in the C's. I have two more citations of the Open Science Collaboration and these are correctly in the O's of the bibliography:

Open Science Collaboration. (2012). An Open, Large-Scale, Collaborative Effort to Estimate the Reproducibility of Psychological Science. Perspectives on Psychological Science, 7(6), 657–660.

Open Science Collaboration. (2015). Estimating the reproducibility of psychological science. Science, 349(6251).

But these are single author publications. I have tried putting the "Open Science Collaboration" name in double quotes (suggested here: ) and also tried putting the entire name in the last name field, the first name field, and as a single author field (the other mode). None of these seem to fix the problem.

I have looked and cannot see any difference between the properly formatted references and the one that breaks.

What can I provide to help fix this?
  • edited February 18, 2019
    Even worse, I discovered that the paper does not officially have the co-author listed, so I eliminated that and now it **still will not sort correctly** no matter how I change things or even if I start from a fresh entry!

    Exporting as RDF shows that all three of the papers have identical RDF code for the author block. I cannot paste it here because it will not format. I created a Github gist to show my RDF:

    This is the RDF from the entry with ONLY ONE author since I found that needed correcting.

    Any ideas?
  • edited February 18, 2019
    This is not related to the earlier issue that you posted to.

    The three entries sort correctly for me here, when I import them and add them to a document (with a mixture of other references to confirm the sort position). What may be happening is that (a) the author field in the bad-sorting reference was once set to two-author mode (so "Collaboration", "Open Science" in the UI), and added to the document in that form, and (b) it was subsequently changed to single-field mode. Due to a long-standing bug in the citation processor (a fix for which is queued for release), changes to the entry in Zotero after it is added to the document do not take full effect in the bibliography, unless you switch the document to another citation style, then back to the desired style.

    To check that out, try switching the document to another style, then back. That should clean up the sort.

    In the next release of Zotero, edits to an item will be correctly reflected in the bibliography automatically.
  • edited February 19, 2019
    Hmmm. Well fortunately for me, but unfortunately for testing the suggestion you made, the document appears to be fixed now that I have switched to a different computer and refreshed it. Maybe the switch between computers, and therefore using a different copy of the zotero program, did the same thing that changing formats would have done.

    Thanks for the help!
  • Yes, it would have. It’s very likely the case that what Frank suggested was the cause here.
Sign In or Register to comment.