Can't add new citations due to 'CSL error'

Hello, I'm having a problem adding citations to my document. First time this happens. The error I get displayed on my document is below. Any ideas on how I fix this?

I tried unlinking the citations and adding new ones, but it keeps doing it. It also seems to do it with any type of references I would like to add and not only this one.

Zotero experienced an error updating your document.

CSL error
TypeError: this.registry.citationreg.citationById[c[0]] is undefined
citationID=M6pojD3o
noteIndex=0
at array citationsPost index 0, from citation at document position 10
  • Done, tried all the option so far Report ID 1875316527 submitted.
  • Revert from Zotero beta to stable (download from the main page and reinstall). The current version has a bug in the Word integration module.
  • Hello,

    I was experiencing the same issue of Joselareta.

    The following pop up alert used to appear anytime I try to add a new citation:

    CSL error
    TypeError: this.registry.citationreg.citationById[c[0]] is undefined
    citationID=4rsPsNEr
    noteIndex=0
    at array citationsPost index 0, from citation at document position 0


    This is my software version detail:

    Zotero v. 5.0.59-beta.1+93bccf8fe

    MAC OS version 10.9.5

    MS Word for MAC 2011 V. 14.0.0


    Then I disabled the automatic update in Zotero -> Document setting and it seems working fine...

    Hope it might help,

    Alessandro
  • @alessandroc: Your issue would be different from the above, and postponing citation updates isn't a real fix. You should switch back to the current stable version of Zotero (you're on an outdated beta) and also upgrade to version 14.7.7 of Word 2011. If you're still having trouble, start a new thread.
Sign In or Register to comment.