Zotero not saving files

Hi. Zotero 5.0.60 standalone on Ubuntu 16.04 installed through flatpak (directory update problem solved) refuses to save pdfs as of today. There is no problem to import the pdfs via the Firefox Quantum browser. The problem comes when I try to save the pdfs into Zotero from the OS, be it drag-and-drop or through the contextual menu option. It won't import the file. I've been using Zotero for years, and such thing never happened before. Moreover: I just paid the annual fee for unlimited storage, but even if it does sync ALMOST fully, it reports some unspecified bug (report error 1648889840)
Workaround is to upload the pdfs directly into the webpage interfase, I guess this will eventually sync back (I read in a different, iOs device). It is, however, a nuissance.
Lots of debate in the forums about the correct way to install the stand-alone. Some orientation would be greatly appreciated.
  • There's no debate about the correct way:
    The official way of installing the app on linux is to unpack the tarball and run Zotero, so if anything doesn't work on linux and there aren't dozens of reports already, you'll always verify the error exists on that set up.

    As for how to install on linux/Ubuntu - given his track record, I'd put a lot of faith in the .deb provided by @emilianoeheyns though it's still an unofficial, third-party build.
  • edited January 28, 2019
    I've just issued a pull request on the Zotero build setup which would allow them to build their own debs as part of their release, but I install my own .debs as part of my tests I run on CI, so they seem to work consistently.
  • Thanks, seems I'm following a wrong path. I'll try what you suggest, and will report if everything goes right.
  • (and even though it is true it is 3rd party, it's not a build as such; the debs from the PPA download the official binaries from the Zotero servers during install and just put the files in the right places -- I don't really build Zotero myself)
  • I left this operation to a time where I had no pressing deadlines. Well, this became a nightmare. I tried both the downloading of the tarball and the installation of the indicated ppa. Connection between zotero and either firefox and opera was totally lost. Tried authorizing the port with the reccomended port, no results. Any hints?
  • edited February 28, 2019
    The PPA requires python to be installed, I don't know if that's the case for Chromebooks. Can you see if zotero got installed into /usr/lib/zotero ?

    If not, you can try the debs from https://github.com/retorquere/zotero-deb/releases (which don't download but directly bundle Zotero, which isn't allowed on PPAs); if that works, I'll un-supersede them and keep them up to date.

    (edit: I had threads mixed up, disregard what follows) I don't have a chromebook so I can't test these there (I test them on Ubuntu); I don't know what kind of barrier exists between deb-installed packages.
  • As per the first post, this is on Ubuntu 16.04, not a Chromebook. You were thinking about a different thread.

    If the tarball doesn't work, something else is wrong, though. Opera isn't tested, so Firefox would be the browser to check this with. When you say "Connection was totally lost" -- what are you actually observing?
  • Oops, sorry.

    I've just started a fresh 16.04 in a VM, installed the PPA and the firefox connector, and it worked without issue for me. I didn't need to authorize anything.
  • It is installed in /usb/lib/zotero It won't do. Funny thing is, it does not report Zotero as not running. The Zotero buttom becomes un predictable (swaying from general purpose icon to webpage to article, tested on a Jstor article), but it performs no action when pressed. I did authorize the saving of information from the plugin preferences. Firefox 65 (64 bit), zotero 5.0.60, plugin just downloaded from the Zotero website, Ubuntu 18.04.2 LTS
  • Yet, the preferences page of the plugin indicates that "zotero is currently unavailable"
  • And, the ping ulr is unavailable
  • Anything unusual about the setup? Proxy, special security software, etc?
    Zotero is tested on Ubuntu (and has tons of users) and this certainly isn't a general problem, so in all likelihood it's something about either your set-up or your install that's breaking this.
  • The environment you describe (18.04 64 bit) is my day to day environment.
  • OK, solved. This is what I did:
    $ sudo nano /etc/environment

    check proxy configuration there. I added the following lines:


    Works fine, either in Firefox or Opera. Thanks a lot.

  • That's not a correct solution. localhost:23119 isn't a proxy address — it's the address that Zotero's HTTP server binds to and the Connector connects to.

    Do you mean that you entered 'localhost' in NO_PROXY? Because if you're using a proxy server, localhost does need to be blacklisted from proxying (and should be by default in any sane configuration).
  • I thought Zotero had switched to using instead of localhost?
  • Well, same thing, but yes, for the setting, it would probably need to be entered as, as noted on the support page. (Both 'localhost' and '' should always be in the default proxy blacklist, though.)
  • There is a difference between the two, although generally it's nothing anyone would notice. But localhost goes through the resolver, doesn't, so I thought maybe that makes a difference when a proxy selectively proxies.
  • Yes, it probably does — DNS resolution most likely isn't performed when comparing to the blacklist.
Sign In or Register to comment.