zotero Word non responsive after laptop update

edited January 15, 2019
I changed my laptop. The Word integration is now completely non responsive.

In new docs, after adding a new citation, the citation is found but not added. After that on adding citation I get the message "you must place the cursor in a zotero citation to edit it". Wherever I am in the empty document. Biography, Prefs, Refresh: all give errors with different messages.

In new new docs (just half an hour later), Zotero is still there and kicking, but completely non responsive in Word

In existing docs I do not get errors, but add/edit citation does not show the selected citation to add at all, and Prefs or Updating gives 'attempting to generate bibliog. without having updated processor items'

So basically: Zotero's out of order.

What can be the issue here?


ps: Windows10, Office365, Zot5.0.60
  • edited January 16, 2019
    Start by closing Word and reinstalling the plugin into Word from the Cite pane of the Zotero preferences.

    If you're still having trouble after that, let us know exactly what happens in a new document, and let us know what exact Word version this is.
  • Reinstalled before, but maybe with Word running. Anyway, after reinstall without Word everything works fine.

    But after next reboot, using a Word-file with Zotero citations and bilbliogr. : "Microsoft Visual Basic error: Run-time error 5097: Word has encountered a problem." Same message whatever option I try in the Zotero tab within Word.
    Zotero running or not running does not change anything.
    New blank document: same thing, same message whatever Zotero button I try in Word.

    Exit Word, reinstall Word plugin (under Cite in Zot. Prefs): same error.
    Reboot, reinstall Word plugin: same thing, same error.
    Blank doc or not: same error

    Tried some more options within Word Options Add-ins, but errors stay exactly as stated above.

    Word for Office 365 MSO (16.0.11126.20234) 32bit

  • Thanks. Works. Thing is that I followed advise here: https://forums.zotero.org/discussion/67032/change-date-format-in-zotero-5
    I changed my regional format to 'english (Sweden)' to get a YYYY-MM-DD format.

    Am I correct that that's the only solution to obtain YYYY-MM-DD? And due to the Word bug currently unavailable...
  • Again Zotero not available in Word. Edit citation in existing Zotero item in Word gives me:
    "Zotero.exe: Zotero experienced an error updating your document. This command is not available. [insertFieldRaw:d:\users\build\cygwin\home\build\zotero-word-for-windows-integration\build\zoterowinwordintegration\document.cpp]"

    Closed Word & Zotero, opened Zotero, updated Word add-in, edit existing Zot. item:
    "Zotero integration error: Zotero experienced an error updating your document. Could not find a running Word instance. [getDocument:d:\users\build\cygwin\home\build\zotero-word-for-windows-integration\build\zoterowinwordintegration\document.cpp:135]"

    I can create a new document with Zotero citations + bibliography without problems. But saving + reopening creates the above (2nd) error message.

    Rebooted and reinstalled add-in again. Word 365, version 1812 (Build 11126.20266 Click-to-run)

    Solved: run Zotero as Admin.. But why?
  • Could you produce a Debug ID from Zotero?

    1. In the Help menu, go to Debug Output Logging and select Enable.
    2. Perform the steps that produce the "Could not find a running Word instance" error (i.e. open a saved doc and try editing with Zotero).
    3. Return to Zotero Help → Debug Output Logging and click Submit Output, which will disable logging and submit the output to zotero.org. A window should pop up containing a Debug ID. Click “Copy to Clipboard” and paste the Debug ID into this forum thread.
  • D1874141938
  • The file is stored at "D:\_\kjk.docx". Have you tried storing it somewhere else where the path doesn't include non alphanumeric characters?
  • Tried just yet: same results
  • Are you opening this file by double-clicking on it? Does it make a difference if you launch Word separately and then use File -> Open to open it?
  • makes no difference
  • Could you produce a Debug ID for a successful Word interaction before the file is saved?
  • D76677700
    strange: I received the error when I tried while another Word-doc (with Zot. citations) was still opened. Only after closing that doc, the new document was fine when I added a citation.
  • All this points to Word running with elevated privileges or as different user than the one that Zotero is running as on your machine. Or perhaps some Windows permissions bug. We've had reports of users being unable to use integration unless they run Zotero as admin for a while, but we could never reproduce it ourselves. The convoluted workaround to this is to create a new user account on Windows, where the problem wouldn't be manifest.
  • It's an enterprise machine. Luckily I can run Zot. as admin. But creating a new user account is not a serious option for me: getting one Windows account to do what I want how I want it is hard enough (and IT would prob. revoke my admin status ;)
    About elevated privileges and Word running as a different user than Zotero: that's above my Windows knowledge..
Sign In or Register to comment.