Problem with existing references after transfer to new computer


I have a new computer to which I transferred my wordfiles, installed Zotero, added word-add on.

I was using a Surface pro with:
- Windows10,
- Ms Office 2010 professional Plus 2010,
- Zotero 5.0.60-beta.1+a557f9211 -

Now I am using a Thinkpad with:
- Windows 10,
- Ms Office 2019 professional
- Zotero 5.0.60

I can add references to my document, I can make a biography but the PROBLEM is that I cann't change or updat existing references.

As I am in the middle of my phd thesis, this is a big problem. Hope anyone can help me to solve this problem.
  • When I try to add/edit a citation I don't see the citation in the Zotero window
  • edited January 12, 2019
    Could you say more? What exactly are you doing and what exactly is happening? See Steps to Reproduce.

    What kind of change are you trying to make to the citation? Generally speaking, if you need to change something about the citation, you should fix the data in Zotero itself, not edit the citation. The exception would be if you need to add a locator such as a page number, which you can do through the editing interface.
  • I tried adding a pagenumber to my existing reference and tried adding an second item to the same citation making it a multiple citations.
  • You still need to say more about what you're trying and what's happening. We'd also want a Report ID.
  • as I said, I am just adding a pagnr to an existing citation (made on my Surface). The windows that Zotero shows are empty, the existing citation is not there so I cann't change it.

    I can add a new citation and update the pagnr without problems. So Zotero seems to function ok then. The problem is just with existing citations.

    would it be helpful to send a page? or a screenshot (which cann't be added in this comment)?

  • report id has been sent
  • (You need to post the report ID here, just sending them doesn't do anything)
  • And yes, a screenshot would be helpful. You can upload one somewhere (e.g., Dropbox) and provide a link here.
  • strangely enough I don't see a report id. It starts with a notice of a Java script error

    it is just 1 screen shot, it would be easier to mail it, is that possible?
  • It gives you the Report ID after you submit the error.

    You can email the screenshot to with a link to this thread.
  • thx.
    Rapport id: 813719430
    screenshot has been sent
  • The screenshot shows the classic Add/Edit Citation window, which doesn't allow editing of items that have been removed from your database, as is likely the case here. (As for why that is, I couldn't tell you — you may have deleted it, or your libraries may not fully be in sync.) Switch back to the default dialog from the Cite → Word Processors pane of the preferences and you'll be able to add a page number.
  • It has not been deleted from the library since I can add it in a new citation.
    Using the new interface (in stead of the classic doesn't solve the problem [I sent a screenshot thru email)

    I synchronized the database, but this introduces a NEW PROBLEM: all my database-items have dubbled! All 'new' items have the same date of 28 Dec 2018 ???
  • That sounds like you used Import and Export to transfer your database? That would cause that
  • Possible, domeinen helper me. What can I do? I have a fairway recent copy (
  • I think no export-import as the database is on my external drive.
  • edited January 13, 2019
    If you have duplicates, you definitely used export/import — that's how that happens. So when you went to edit a citation, it wasn't actually in your database on that computer, and when you inserted one, you were inserting the duplicate.

    The easiest way to clean up the duplicates at this point is to sort your library by Date Added and delete the set of items that you imported rather than synced. You should be able to identify those because they'll all have the same Date Added, whereas the originals will have varying Date Added values based on when they were actually added to your library.
  • is there a smart way to do this or do I have to do this one by one?
  • I explained how to do this efficiently.

  • yes but I meant is ther a way to select all with a certain date and delete in one go?
  • found it, done.
    what do I do next?

  • changing existing references seems to work fine now. Do I need to sync again?
  • You should generally leave auto-sync enabled when using Zotero.
  • Everything seems to be working again, so this discussion can be closed.
    Thanks for your help!
Sign In or Register to comment.