help getting Zotero buttons to work in LibreOffice Writer; worked once then failure

I would like help getting Zotero citation and bibliography buttons to work in LibreOffice Writer.

At first my first and only citation insertion worked, but I deleted it and have not been able to recover.
In LibreOffice Extension Manager I eventually removed the extension, then I followed
to manually install 5.014 from the downloaded and extracted extensions folder.

I am using Zotero 5.0.59 with LibreOffice under KDE Neon 5.14 (Linux).
I have not used Zotero for 8 years and over the last days added it to both a desktop and laptop and signed into my old account. I am having the problems on the desktop so far.

Before I uninstall LibreOffice and Zotero and start all over, maybe there is a more elegant path to success? (Or would that also fail because of some leftovers?)

  • What exactly happens when you try to insert a citation in a new document?
  • No response.
    I just opened a fresh document, entered some text and clicked the insert cite button.
  • Just to make sure you have the latest extension, try removing the extension completely from LibreOffice, confirming that it's gone, and then reinstalling it from the Cite pane of the Zotero preferences.

    If that doesn't help, see the Installation Error steps for confirming that the JRE is configured appropriately and checking what version you have.

    Moving your LO profile directory out of the way could also help.
  • Thanks, dstillman,

    On the desktop I restored the extension from the Cite Pane and it works.

    On the laptop I can insert citations.

    But I do have other difficulties. My Zotero library on the laptop does not have sub collections.
    I can see them in the libary in Firefox.

    (Also, I can not do a fresh start from the KDE launcher by clicking on the icon, but need to execute the zotero script.... (same on desktop. In both cases once started Zotero remains active between reboots unless I close it.)
    I am a Linux user not and expert or hacker. The installation instructions could be clearer...)
  • My Zotero library on the laptop does not have sub collections.
    Meaning there's no left-hand pane or you see My Library but don't see any collections under it?

    If the former, the left pane is just collapsed, and you can click along the left edge to restore it.

    If the latter, do you see the trash? If not, My Library is just collapsed and you can click the arrow to expand it. If you see the trash but no collections, it's possible you have fully synced. See Changes Not Syncing.
  • I had to reposition Zotero to see the open handle to open it.

    Thanks again. I'm in business now.
Sign In or Register to comment.