Problem during changing style of citation

Hello,

So I have a document I work on. At the moment, I insert a citation in footnote style (Chicago). However, when I change (in word via Zotero plugin) citation style to author-date (in-line) and then switch back to footnote, it puts all or majority of citation in one place (on one word).

Did anybody experience it, does somebody has some idea what causes it?
  • This is not a general issue. What version of Word are you running (such as 16.20)? Can you reproduce it in a new document? Can you make a small snippet of your document that reliably reproduces the issue and send it to support@zotero.org with a link to this thread?
  • I presume I have Tha latest word as I am paying subscription to world) 365, or what is it called). Can check if I know how when I get home from the doctor.

    Also I tried to reproduce it in New file by adding randomly generated text and then adding citation in Chicago full note one per page on 6 pages total. Then I changed it to inline and then back to full note. Still 5 out of 6 citations in row next to each other on one word I presume where I had my cursor.

    Will try to add a upset once home.
  • We need a precise version of Word to troubleshoot this.
  • It is version: 1811 (Build 11029.20108)

    And the image of the wrong citation placement after changing the citation from full note Chicago to author-date and then back via the Zotero word plugin.

    https://www.dropbox.com/s/xye7yceowek3m71/Wrong citation on cursor.png?dl=0
  • I am unable to reproduce it with the same version of Word. Are you using a custom Word template, possibly one that did not come with Word? Do you have any other Word extensions installed?
  • Nope, I do use a new blank page. Tried to replicate the error in a new blank page from word without formatting anything and still happening. Only other plug-ins in the word are Grammarly and Mendeley.
  • Does it still happen if you disable those plugins? You can do this under Word Options -> Add-ins, selecting the appropriate management section at the bottom and pressing "Go".
  • Yes, still. But noticed I have two Zotero plugins .dot and .dotm
  • The multiple Zotero plugins shouldn't be an issue although you can safely disable the .dot version.

    Can you replicate this issue with just 3 references and minimal text in the document and provide the steps? If not, can you send that minimal example to support@zotero.org with a link to this thread, before the 2 conversions that displace existing citations?
  • I was thinking about reinstalling word. So I uninstall Office 365 and reinstalled it. But all plugins are back. Do I need to somehow manually remove it?
  • Reinstalling Word won't remove the plugins as they are part of user preferences stored within your Windows account folder. If you have tested with the plugins disabled and the issue still occurred then there is no need to remove other plugins from Word.
  • Also one more thing. I was installing into Zotero rtf/odt scan in order to scan citation imported from Scrivener over the libre office. Maybe the plugin messed up somehow Zotero, because as already mentioned, even in a new file with 2 citations alone Zotero messes the numbers etc.

    So I uninstalled it, but still happening. I would reinstall Zotero, but I have a Library with NOTES. I am scared that even when I export library, it won't save notes.
  • Meanwhile, mendely does not have the same problem. From some reason, it is only Zotero.
  • Could you maybe provide an example of what you're seeing? I'm still having a hard time following.
  • edited 10 days ago
    You mean this? Already posted the image though.

    It collects all citation in the document [in-line] and places it like onto the same location where my cursor is. Meaning it does not place citation number on where it should be when changing from inline citation to footnotes.

    https://www.dropbox.com/s/xye7yceowek3m71/Wrong citation on cursor.png?dl=0
  • ah yes sorry. Highly unlikely this is related to ODF scan, though you can obviously disable that, too.
Sign In or Register to comment.