Can't save from Firefox connector

This discussion was created from comments split from: Standalone + Firefox connector : No "save to zotero" option?.
  • edited January 5, 2019
    Report ID: 2106511338
    Hoping someone here can help me out with a problem. I have both Zotero Standalone (v4.0.29.17) and the Firefox connector (v5.0.7). If I look at the Firefox Manage Extensions/Options status it says that Zotero is currently available and it says the connector will save to when the Zotero standalone is not open. That doesn't seem to matter, though, because when I push the Zotero button in the browser (the small page add-on that replaces the Z), nothing happens. When I look under Manage Add-Ons/Advanced this is what it says:

    "JavaScript Error: "_tabInfo[] is undefined

    What does this mean and what can I do about it? I've already removed and re-loaded both the standalone and the browswer extension.
  • You're using extremely out of date versions of Zotero and the Zotero Connector. Start by upgrading to the latest versions, including Zotero 5.
  • Wait, your error report shows that you have version 5.0.52 of the Zotero Connector. Why did you say you have 5.0.7?
  • In any case, make sure you have the latest version of Zotero 5, and then if you're still having trouble see Troubleshooting Translator Errors.
  • edited January 5, 2019
    Sorry, just a typo. I've downloaded fresh versions of everything and they still don't work.
  • It's working now; thank you!
  • Out of curiosity, what fixed it?
  • I've encountered same issue with 5.0.55. The reason in my case was that the browser tab was already open _before_ installation of the plugin. The same error appeared in the console and nothing happened when clicking the add-on button. The solution was to refresh the page or to open the same page in a new tab.
Sign In or Register to comment.