Zotero is not updating citation numbers in text but in bibliography

edited 13 days ago
I am currently writing my BA thesis and am experiencing some difficulties regarding Zotero. Up until now I have about 35 sources quoted and most of the citations are working fine. But every now and then they seem to fail to update. E.g. I have the sources 1-5 quoted individually and they show up perfectly fine in the bibliography. But then the next sources are multiple quotes and should be 6-9 but are showing up as 4-7. This is really wrong as they are different sources than the ones I quoted individually (otherwise it would of course make sense if they are numbered the same)
Funnily, in the bibliography the sources 6-9 are the ones that should be quoted where it says 4-7 in the text.. but now the problem repeats itself for the following citations 8 to 9 in the text..

I hope I was able to make my problem clear as it is quite complicated to write out..

I already tried a lot.. Restarting word, refreshing citations, deleting and adding the bibliography, changing the style as well as deleting this multiple citation completely and adding it again... it comes up as 4-7 again

I am using Zotero in word 2016 for mac (Version 16.8) and am using the nature style





Right now I just tried to view my document preferences.. and I think the whole system does not want to work with me anymore :D I am not able to view my document preferences anymore.. If I try the red "edit citation" box appears for a random citation somewhere in the text..
Sign In or Register to comment.