Import from Clipboard Verbatim (eg \'e not é)

I have a question that is related to [https://forums.zotero.org/discussion/63366/importing-bibtex-with-italics-superscript-and-subscript], but is slightly different.

I use BetterBibTeX, using Zotero for referencing my maths papers. This means my titles sometimes have things like $-signs in them. I use the tag #LaTeX to make Zotero output verbatim the title (eg $Z^2$ is outputted exactly as this, not Z with a superscript 2). However, for *importing* from the clipboard, this does not work quite as I would like. Consider the following example bibtex data. (This is a real example of one that I'm using. I use MathSciNet to get my bibdata.)

@article {MR2992954,
AUTHOR = {Lladser, Manuel E. and Poto\v{c}nik, Primo\v{z} and \v{S}ir\'{a}\v{n}, Jozef and
Wilson, Mark C.},
TITLE = {Random {C}ayley digraphs of diameter 2 and given degree},
JOURNAL = {Discrete Math. Theor. Comput. Sci.},
FJOURNAL = {Discrete Mathematics \& Theoretical Computer Science. DMTCS.},
VOLUME = {14},
YEAR = {2012},
NUMBER = {2},
PAGES = {83--90},
ISSN = {1365-8050},
MRCLASS = {05C80 (05C12 05C25)},
MRNUMBER = {2992954},
}

When I copy this and then do "import from clipboard", Zotero changes some stuff. For example, it puts the accents over the letters in the people's names -- and not always correctly, eg writing "Potǒcnik". (Additionally, in the FJOURNAL entry, it removes the \ from \&, but I don't actually use this data at the moment.)

I would like Zotero to input **verbatim** the title and authors. (It already outputs verbatim.) Any advice would be most appreciated! :)
  • The accents being placed wrong was BBTs fault; BBT 5.1.36 has been released to address this.

    Verbatim import is no longer possible in BBT; it used to be possible in the 4.x series, but the new parser doesn't support it. The \ before \& being removed is part of this; \& "means" & in BibTeX. Math import suffers the same issue.
  • For math formulas you don't strictly need #LaTeX BTW, that can also be done like this: https://retorque.re/zotero-better-bibtex/scripting/#detect-and-protect-latex-math-formulas
  • Thanks for your response. I always let Zotero do its updates, but I'm not sure how to manually make BBT check for an update, or even see what version I have. I suppose, since I use BibLaTeX, I need the .bib file to have things like \'e, not é, in the files -- if I write "Namé" as an author, then doesn't print the character -- so it doesn't really matter if the BBT parser understands the accents correctly or not: I have to replace them manually anyway :)

    And for maths formulae, I did see that before, but for some reason I used #LaTeX. There was a specific reason -- the above postscript didn't work in all circumstances -- but I forget which!
  • UPDATE: I've just tried it, and it seems that now BibLaTeX does support "Namé"! If you type "Namé" into the main part of a LaTeX file, then it doesn't print anything. So it seems that I probably don't need to go through them manually, once I get the up-to-date BBT :)
  • If you want "é" to output to "\'e", you have to have "export unicode as plain-text latex commands on" in the BBT preferences, which for BibTeX is the default. For BibLaTeX it is off by default, but BibLaTeX has supported unicode for some time.
  • Thanks for your response. I have ticked "Export unicode as plain-text latex commands" for both BibTeX and BibLaTeX, but it still outputs "Namé" as "Namé" not "Nam\'e". As you say though, BibLaTeX does support "Namé"...
  • That must be a different character composition then. Could you do me a favor, right-click on that reference where you see the problem, submit a BBT error report, and post the debug ID in a BBT issue at https://github.com/retorquere/zotero-better-bibtex/issues
  • edited 15 days ago
    I just made a new reference, and calling the author "Namé" outputted "Nam\'e", but it doesn't if I edit the previously mentioned reference.

    I've submitted an error report, but just before I post on the forum, let me check one thing: I was editing an old auto-update .bib file; might this not accept the new "export as plain-text"?

    In fact, to answer my own question, I've just seen that I need to tick it there also! Although, even though I've ticked that, it still outputs "Namé"
  • Please don't change the previously mentioned reference yet! If you can export it to "BetterBibTeX JSON" and get that to me (that's what the right-click-send-report does among other things) I can investigate, but if the problem no longer occurs, I can't fix it.
  • What was the report ID?
  • Report ID: KMQMSGHH-euc
  • Ah right -- as of a while ago, that setting is private to the auto-export, not global. Sorry, missed that.
Sign In or Register to comment.