CAPTCHA from Google Scholar citations plugin

This discussion was created from comments split from: Google scholar not working.
  • When I try to update my citations, I get this error: "Please enter the Captcha on the page that will now open and then re-try updating the citations, or
    wait a while to get unblocked by Google if the Captcha is not present." But when Chrome appears, there is no Captcha. I'm using my university's proxy which I suspect may be part of the problem. Any thoughts on a solution?
  • edited 20 days ago
    Follow the advice of @bwiernik (above) about establishing a GS library.

    See:
    https://www.zotero.org/support/kb/site_access_limits

    See also:

    https://www.zotero.org/support/getting_stuff_into_your_library [to your Zotero library]

    scroll down to "large scale imports ..." and also further down to "verify and edit ..."
  • edited 20 days ago
    I've encountered the same problems, and basically (as lots of people have pointed out) you run into GS limits. The issue is that the connector needs to make lots of queries to add all the papers.

    One solution is (as @bwiernik suggests) to save items to your GS library, and then export bibtex. It doesn't give you links/DOIs (if I remember correctly), which is a bit of an issue, but you can then look those up later (not convenient, but OK).

    However, another solution is that you simply follow the link: I.e. on the google search page, click the link, and then add the paper from the resulting journal page (or PDF). Clearly also not convenient, but another workaround.
  • @bjohas offers the best practice. Following the links to publishers' sites will provide you with more accurate and complete metadata. Metadata directly from GS often contains an incomplete listing of authors, the order of authors is commonly different from the order listed on the publication, and (although much less common than a year ago) the journal name in GS metadata is sometimes wrong.

  • Thanks...unfortunately I have almost 500 entries in Zotero and so the manual process of creating an entire GS library or looking up each entry manually, would take more time than I have. I appreciate your thoughts.
  • I tried one more time to get the citations plug-in to work and I was no longer getting the GS error message but I noticed my citations are all reverting to "00000". So I uninstalled/reinstalled the plug-in but it's still replacing all of the numbers in the "Extra" field with "00000" which is destroying what I already had for many of the entries
  • edited 19 days ago
    @jelarv: It sounds like you're using the GS citations plugin. That's not what the original thread was about — that was just about saving from Google Scholar — so I've split this off. If you're using that plugin, you pretty much just need to either disable it or be content with waiting days between attempts. It's not really possible to use it in current versions of Zotero (which don't run in the browser with a shared cookie store that you also browse the web with) without being quickly blocked by Google Scholar.
  • @bjohas GS just doesn’t have DOIs in their data. You can use my DOI Manager plugin to automatically retrieve DOIs or shortDOIs on item import.
Sign In or Register to comment.