Zotero in Google Docs does nothing

When I click or attempt to add from menu, literally nothing happens, no error, no dialog, nothing.

I tried in completely new, blank, document with the same negative results.

Latest Firefox 64.0 (64-bit), Zotero version 5.0.59

Thanks in advance.
  • I assume you've tried restarting Firefox?

    Can you provide a Debug ID from the Zotero Connector for loading Google Docs and trying to insert a citation?
  • I have the same issue both in Chrome and Firefox. Debug ID: D2051241234.
  • Do you have any other browser extensions installed into Chrome and Firefox? Do you have the Zotero client open when trying to use the integration?
  • I disabled all other extensions in Firefox, refreshed the page with a new google doc, confirmed that I have the Zotero client open (Zotero connector extension's settings page saying "Zotero is currently available") and still have the same issue.

    Here is a new Debug ID: D498241928

    Every time I click one of the Zotero buttons/menu options, it seems line the following
    errors show up in the debug log:
    (3)(+0000005): Connector: Method document/execCommand failed with status 503
    (3)(+0000002): Method undefined failed
  • edited January 10, 2019
    Also in the debug output for the Zotero standalone I get these errors with every command on the Google Docs page:
    (3)(+0000002): Integration: Request already in progress; not executing http addEditCitation
    (5)(+0000002): HTTP/1.0 503 Service Unavailable X-Zotero-Version: 5.0.59 X-Zotero-Connector-API-Version: 2 Content-Type: text/plain Integration transaction is already in progress

    So it seems that the command (here "addEditCitation") gets to Zotero Standalone, but fails there.
  • Ok somehow after restarting Zotero Standalone everything started to work both for Firefox and Chrome! :)

    Seems like it was stuck in some "Request already in progress" state that was resolved after restarting...
  • Thanks so much. I had this same problem and reopening the Zotero desktop app worked for me as well!
  • keeps saying zotero is updating your document, please wait

    will be stuck on this for a crazy amount of time
  • I had the same problem, but then found out that there was a dialog window in the background from the Zotero standalone asking you to select formatting style. Try Alt-tabbing to find this window
Sign In or Register to comment.