Can't sync due to fields being too long

Hi, I keep receiving the same error message, saying that my library can't be synced because the creator name in one of my items is too long. It advises me to shorten the field and sync again, which I do, but then it will just come up again. I also tried deleting and re-adding the respective item, but it doesn't work either. Every time I try there is a new item that has a field too long - I've been using Zotero for a few years and I never had this problem before. I'm a little worried, as I haven't been able to sync in a while now...
Anyone ever had the same problem?
  • edited December 7, 2018
    The message really means what it says, and the same length restrictions have been in place for years. Note that if you delete an item instead of simply correcting it, you need to empty the trash as well. But there's no need to delete an item if you want it — you just need to fix the field that's too long.
  • Basically, though, you can see the data in the item it identifies, so there shouldn't be any mystery as to what's causing this. If all the affected items are from the same site, there might be a problem with a translator pulling in incorrect data, and if you saved a lot of items from that site you'd have a bunch of items that you'd need to correct. If that's the case, provide an example URL so we can take a look.
  • Thank you for your answer. Most often it is the Editors field that is too long, but I don't find it to be the same site everytime... One of them has been from this site: https://www.journals.elsevier.com/journal-of-affective-disorders
    If I correct / shorten the field I think is too long, I get the same message again for a different item.
    Thanks a lot for your help.
  • We would need a specific URL that you saved from, which should appear in the URL field for the affected item. (A DOI night also suffice.)
  • Could you say exactly how you're importing? If I just import articles from that journal, it doesn't import any editors (nor should it, I think) and everything looks correct.
  • Thank you for your comments and please excuse my late reply. Here is the DOI of the latest item that is too long: 10.1016/j.chiabu.2017.07.021, it doesn't have an URL.
    I always import using the Zotero icon in the Firefox browser.
  • Hi there, I keep having the same problem. Any suggestions on how to solve it? I'm afraid my library won't sync correctly and as it is very important and valuable to me, I would rather avoid stuff being lost. Thanks a lot
  • edited January 16, 2019
    I still don't know how you're importing that. Both by going to the page on Sciencedirect via the DOI and by importing the DOI in Zotero via add-by-identifier, I don't get any editors nor any other string that'd be too long for syncing.

    If you get overly long author strings somehow, you'd just delete or reformat them.

    Edit: and if you keep getting that message, I'm afraid you'll have to fix the length of fields for all items until you stop getting it. There's not quick fix here.
Sign In or Register to comment.