Google's captcha interferes with opening new notes in Zotero

I have re-downloaded my Zotero library on my new computer. Because of the amount of request I now get captchas from Google Scholar. In addition, I have a problem that I didn't see mentioned elsewhere: whenever I open a new note in Zotero, there is a message error on Zotero that redirects me to the default browser (Safari), and then I see this: "Your search - allintitle: - did not match any articles." It's very annoying and it's slowing down my work.
  • Current versions of Zotero don't use Google Scholar at all, except when you save from Google Scholar in the browser using the Zotero Connector.

    If you're using the third-party Google Scholar Citations plugin, uninstall that from Tools → Add-ons.
  • Thank you. I uninstalled the third-party Google Scholar Citations plugin and the problem went away. I really like that plugin though. I tried to re-install it and the problem came back. Will I be able to use it agin in the future?
  • We don't make that plugin, so you'd have to ask the developer (who might not be maintaining it anymore). But Google Scholar can be very strict about blocking automated requests, and that's been exacerbated by Zotero's switch to being a completely standalone program rather than a version that ran within Firefox and shared the browser cookie store, so I'd guess not.
  • Too bad! Thank you for your prompt answers.
  • Would that change if I use a VPN?
  • edited 12 days ago
    Simply using a VPN will not resolve the GS limits imposed if their system "thinks" you are downloading too many items. The Google system is "smarter" than most of our abilities to attempt getting around their limits.

    Although the metadata available from GS has greatly improved over what it was you will almost always get more accurate and complete metadata if you follow the GS link and gather the metadata from the journal publishers' websites. GS metadata often has serious errors. If a reviewer or a professor checks your references and they have GS imposed errors the person may not find the source you cite. That could result in severe consequences.
  • @DWL-SDCA They are specifically interested in gettting Citation count data from Google Scholar, which appears to have substantially more coverage (and be freely available) compared to other citation sources

    @seredes You could use the plugin but disable the feature to automatically update the citation count on import, then only get citations as-needed.
  • @DWL-SDCA , thanks, I have tried but that does not solve the problem. The funny thing is that if I use Zotero on my old computer, and I can still update the citation count and then sync it. But it's not a permanent solution.
  • The message above was meant for @bwiernik
  • Yes, however citation _count_ information from GS can be inflated because (unlike Scopus, Web of Knowledge, etc.) GS citations are derived by machine observations without human input that removes duplicates. Also, although perhaps desirable, the GS citation information will include citations from any and all grey literature online.
  • edited 11 days ago
    I’d regard that as desirable. Analyses of GS citation data indicate that it is primarily a superset of legitimate citations (with the additional numbers being primarily journals not indexed or not captured properly by WoS, Scopus, etc.) and that the traditional databases are undercounts.
  • @bwiernik, I am happy to report that the Google Scholar Citations plugin is now working. So the solution to the problem is to disable the plugin for a couple of days and then enable it again.
Sign In or Register to comment.