"Empty response from server" on sync

I have a small library - 226 items - with a 1.3MB sqllite file.

I sync across several computers - three Windows and one Linux. One of the Windows computers, running Firefox 3.0.11, doesn't sync. The other one I can currently test syncs with no problems.

Error report number is 942600469
  • I'm getting this error message also, along with other, more extravagant JS exceptions;-(

    I've been using Sync with 2.0b5 for a while now from one computer without problems. So tonight I decided to bite the bullet and add it to my laptop also. My library seems bigger than the one reported above, about 800 items and an SQLite database of some 12Mb.

    The error report is 522608623.

    I assume I should use "reset" and try sync-ing from the laptop into an empty server store?
  • Error Report Number is 589520569

    I have been praising Zotera and telling everyone I know to use it. But I may have spoken too soon.
    The following text is just the first reported error when I attempted to sync. I’m running 2.0b5 on (vista 64). Please help!
    [JavaScript Error: "uncaught exception: [Exception... "Cannot modify properties of a WrappedNative" nsresult: "0x80570034 (NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN)" location: "JS frame :: chrome://global/content/bindings/autocomplete.xml :: onxblpopuphiding :: line 834" data: no]"]
  • peter.kelly and alandsloane: Can you restart Firefox and let us know if you're still getting the "Empty response from server" message? If so, send in another error report.

    selkin: Your issue isn't related to this thread (and it's not related to the error you pasted in), but you'll need to either wait for the next 2.0 beta release, which might address the problem, or use one of the Reset options. See Troubleshooting Sync Errors for more info, and start a new thread if you still have questions.
  • Restarting Firefox didn't fix the problem, although things are now different! (In particular I haven't seen the "Empty response from server" message lately.

    I tried all the following:
    1. restart Firefox(es)
    2. restart computer(s)
    3. install Firefox 3.0.11 (on both)
    4. uninstall SQLiteManager Extension (I'd not had problems using it with 1.x, but just in case)

    I also "reset" the Server storage via "Zotero>Preferences>Sync>Reset>Restore to Zotero Server". This worked fine from both computers.

    In other words I can upload either DB and it stays in sync happily with that computer, but if I try to sync the second computer, Zotero goes off into a seemingly never-ending loop (Firefox sends me worried messages about a nonresponsive script running variously in xpcom\zotero.js and db.js).
  • Zotero goes off into a seemingly never-ending loop (Firefox sends me worried messages about a nonresponsive script running variously in xpcom\zotero.js and db.js).
  • I will restart and submit another error report - but I have tested that before logging the bug. If you can easily check through error reports from me you'll find one on the previous beta release with the same issue, which was obviously pre-restart.
  • After a few days not using the affected computer, resetting from server fixed the problem and it now syncs again. In case it's relevant I did remove and re-instate my username and password in the interim. From my point of view this can be closed now.
  • I get the same error "Empty respons from server". Zotero 2.0 0b6.
    When I look at the online libary, its not updating.
    Have tried restarting firefox and also settings to reset local to server, but still no sync/updating of server.
  • Think the problem had something to do with me re-organizing collections (moving collections from one folder to the other, including sub-collection).

    Problem solved by resetting, and then uploading to server (overwriting server).
  • Hi all,

    I also have a "Empty response from server" error message. Report ID is 127472218.

    Thanks for a great piece of software!

  • Ooops - just got the same error with 2.0b7. Forgot to search for support before positing my report id: Here's my posting:

  • http://forums.zotero.org/discussion/5206/empty-response-from-server/#Item_17
This discussion has been closed.