little issues with automatically update citations, zotero classic view and mendeley plugin in word

Hi,
I'm starting to use alternative to endnote. I've tried Mendeley and Zotero so far; I found Mendeley too slow so I'll try to continue with Zotero.
Three questions :
-How can I get rid of the mendeley plugin in the word ribbon (References) on word 2016, mac?
-I would like to first put the citation in my text and, in a second time, update the bibliography at once. I unchecked the box of "Automatically update citations" in document preferences but when I refresh, nothing happens. Any idea for this issue?
-When I add a citation, I usely use the PMID. This works only if I use the classic view of Zotero. How can I proceed for having this classic view by default when I want to add a citation in word?

Thank you for your help.
Best
  • 1) Uninstall Mendeley and/or uncheck the Mendeley template from the "Word Add-ins" window in the "Developer" tab in Word (or delete the Mendeley template from the Word Startup folder as described here https://www.zotero.org/support/word_processor_plugin_manual_installation#locating_your_word_startup_folder)

    2) This should obviously just work. How many citations are in your document? If you have a lot, it may just be that it takes a while for Zotero to finish updating the bibliography. Do you have this issue in a new document with only a few citations?

    3) You mean you want to search for items by PMID? Or do you mean something else? You can set the Classic view to default from the Cite pane of Zotero preferences.
  • thank you for your reply
    For uninstalling the Mendeley template, I tried both propositions and the template was not present . However it is still in the ribbon in word. I'll uninstall and install again word.
    Regarding the "automatically update citations" issue, it does not work even with an empty doc. I have the numbers but no references. Also if i insert few references, format the bibliography and insert again others, the numbering is wrong (I have two (1), two (2), etc...).
    For the last point, I found that in Preferences, you can choose to directly access the Classic view. It works well
  • What version of Word and Zotero do you have installed?
  • Regarding Mendeley, here is some advice on removing that plugin: https://groups.google.com/forum/#!topic/microsoft.public.office.misc/F2mxkXGeEdU
  • Zotero 5.0.58
    Word 16.16.4
  • Regarding the "automatically update citations" issue, it does not work even with an empty doc. I have the numbers but no references. Also if i insert few references, format the bibliography and insert again others, the numbering is wrong (I have two (1), two (2), etc...).
    Could you explain the exact steps you're taking, in a new document, to reproduce this problem?

    See https://www.zotero.org/support/reporting_problems#provide_steps_to_reproduce for an example of what we need.
  • It is ok for the last point. I didn't do "refresh"
    thank you for all your rapid help. the zotero community is very reactive.
    I need to manipulate more the software.

    BTW, is there a way to add a reference directly from zotero (without using the word plugin)?
    Thanks again for your advices
  • BTW, is there a way to add a reference directly from zotero (without using the word plugin)?
    If you mean to insert active citations into your document by clicking a button in Zotero, no.

    If you want to add a quick one-off bibliography to any text field, you can use Quick Copy, but that won't keep track of citations or include any of the sophisticated context-aware functionality of the Word plugin, so it's not a replacement for the Word plugin.
  • edited 20 days ago
    Also, just to clarify, you don't need to disable Automatically Update Citations — that's on by default and should generally be left on unless you're working in a large document where updating after each citation starts to take too long. You only need to refresh manually if you disable Automatically Update Citations or if you rearrange/delete citations in your document.
Sign In or Register to comment.