Error Report: 1249293532

edited 27 days ago
Renamed a tag from "Wanted" to "_WANTED"

Had a "Saved Search" which evidently used that tag. Now immediately when that "Saved Search" is selected, Zotero stops, says there is an error and forces a restart.

For the other "Saved Search" items using that tag I was able to fix the search by changing specification for tag name from "Wanted" to "_WANTED".

Edit > Preferences > Files and Folders > Check Database Integrity

No errors found.

Restarting Zotero seems to work fine unless the particular bad "Saved Search" is select, at which point Zotero immediately halts again.
  • Trying to "Rebuild Index..." to see if that automagically fixes the problem.
  • edited 27 days ago
    Didn't seem to help. I glossed over the point that the command is for rebuilding the text indexes not the internal relationships.


    I enabled error logging, restarted Zotero, and clicked on the problem "Saved Search". The debug report is D670361744.
  • Obviously this shouldn’t happen, but you might be able to fix it by right-clicking on the saved search and editing it.
  • I tried right-clicking on the problem "Advanced Search" to bring up the dialog box where I could delete that search. That doesn't work. I'd guess that populating the list has priority over showing the dialog box. :-(
  • I may know how I blew this up, but I am loath to try until I know how to clear the landmine I have in the list of Advanced Searches.

    I link the pdf files for articles in a separate "reference" directory rather than actually importing the file into the Zotero database structure. Thus when I link with the host version the files are not uploaded which saves gobs of time on my slow connection, and keeps my storage limit low. (I only use the on-line database when I go to college libraries to look for journal articles.)

    So I had some pdf files that were stored into Zotero.

    I created a search in Windows that looks for files in the Zotero "storage" directory and its children.

    Now I have the authors name in pdf file name so I can find the item listing in the "My Library" view easily.

    I then would use a shift+left mouse click to *move* the pdf file from the Zotero directory to my "reference" directory. That way the list of pdf files that Windows has created automagically updates to remove that file from the list. If I just copy the file to the my "reference" directory, then the Windows list of pdf files doesn't update until the trash is cleared.

    I *think* that Zotero still thinks the pdf file is there so I moved it to trash. (As I said I'm loath to play with this lest I blow up another "Saved Search".

    After cleaning up all such files I emptied the trash. (Maybe I had renamed a tag before emptying the trash?)

    Sometimes afterwards was when I renamed the tag that the "Saved Search" used.
  • I still have a "Saved Search", which when selected, Zotero stops, says there is an error and forces a restart. Is there any to clear this land mine?

    Tried a right mouse click but that won't work.

    Did a check of DB integrity and get an OK.

    Is there any way for me to fix this?
  • This should now be fixed in the latest Zotero beta.
Sign In or Register to comment.