Fixing Journal Abbreviations in Zotero


I've worked my way through this forum and all the discussions about this very topic. However I couldn't find any working solution since the pluggin by fbennett does not seem to exist anymore (at least I only get a page not found error when trying to access it) and since whenever I try using an abbreviations.json file (and I have just used files I have found in these discussions like from adamsmith e.g.) I get an error message from the word pluggin 'abbreviationCategories is undefined' and I cannot make any citations anymore independent on if they are on that list or not.

Is there anything new on this topic or can anyone help me solving my problem?

The initial reason why I had problems with the automatic journal abbreviation function is that I had false abbreviations for some journals and since I can only either completely switch off this function (meaning I have to type the journal abbreviation into every single entry of the zotero library) or completley on.

So I know that this topic was discussed extensively here but if I've overlooked the solution to my problem or if anyone could tell me about the best option to change abbreviations for certain journals I would be very grateful.
  • There is no obvious solution you're missing, no. I think currently abbreviations.json is the only way to do this in Zotero at all. Can't say why you're getting an error, though. Could you post a sample file you used somwhere (e.g. ) and link to?
  • Thanks for your quick response!

    I've used the following file you had posted in 2013:

    I also tryed with a simplified example like posted by fbennett in 2012:

    "default": {
    "container-title": {
    "European Human Rights Reports": "EHRR",
    "All England Reports": "All E.R."
    "collection-title": {},
    "institution-entire": {},
    "institution-part": {},
    "nickname": {},
    "number": {},
    "title": {},
    "place": {},
    "hereinafter": {},
    "classic": {},
    "container-phrase": {},
    "title-phrase": {}

    Always the same error.
Sign In or Register to comment.