) becomes ]

I have a citation, which should only have a closing bracket (the other half if the bracket content is outside of the citation. Zotero changes the bracket from ) to ]. Why? Is this something in the style I can fix? I am using my own style.

To preempt the obvious question: I can't have the complete bracket inside of the Zotero prefix, because then it will capitalise the ibid (in my case "Ebenda") after "vgl.". Or can this be stopped from happening?
  • ibid shouldn't get capped after a period I thought. Could you post the whole citation, I'm not entirely sure I'm following.
  • It normally doesn't get capitalised, only if there is more than one word in the Prefix field, followed by a period. Not sure if this is something I can influence in the style, if so, that would be good.

    Here is what I get:
    Die Portamenti finden sich auch nicht, wie Milsom irrtümlich schreibt, in den Takten 7, 10 und 18, sondern in den Takten 10, 14, 17 und 18 (in Takt 14 und 18 jeweils zwei Portamenti), vgl. ebenda, S. 99 bzw. 101. Ein weiteres, kaum zu hörendes „Schieben des Fingers“ befindet sich im ersten Takt (von Milsom im Notenbeispiel auch vermerkt vgl. Ebenda, S. 236).

    Zotero fields are underlined. In the second field the "Ebenda" gets capped, which it shouldn't be.

    If I take the beginning of the bracket out of the Zotero prefix, I get a ] at the end.
  • edited November 9, 2018
    Oh right. I _does_ cap the ebd. after the period on purpose. What sort of citation style is this? Couldn't you just take both brackets out of Zotero?
  • The style is mine, I need it for the Beethoven Studien.

    If I take the closing bracket out the period will come before the bracket, that's no better.

    Is there a way to stop it from capitalising after a period? It seems to decide itself what is an abbreviation and what is a full stop, which personally I find a little too much intelligence. There should at least be a way to avoid this from happening. As you can see with the first field it does not capitalise after the period.

    I can think of a different way to word the footnote to avoid this, or just take "vgl." out completely, but I dislike the way this dictates me my style.
  • I think setting explicit text-case="lowercase" on the ibid term might work, but not sure. Otherwise I'm afraid I don't have a good idea.
  • That would probably result in a lowercase ibid even at the beginning of the footnote, no? That would definitely not be the solution.
    Why is this capitalisation done in the first place? I cannot think of many situations where this would be needed.
  • This footnotes makes a declaration that requires a citation. Ibid. 54.

    Based on demand -- and as you can see, there's really no good way to satisfy every demand here.

    I don't know how it tries to guess abbreviations, though. I think there is a thread on the logic somewhere.
  • Your example could easily be done by taking the sentence out of the field, though.

    Whenever there is some logic that tries to "guess" content, the automatism will eventuell get in the way. Unless there is a way to "know", Zotero should not make such a decision, or at least provide a work around. I tried a hard space, but no change.

    Anyway, my original question was about the ] instead of ) if there is no ( preceding it. I can see absolutely no logic here...

  • edited November 9, 2018
    I agree Zotero will get it wrong at times if it guesses, but the point is that it _also_ gets it wrong if it doesn't. It's not like there's a clean solution satisfying everyone here. The code that handles capitalization was introduced because people really needed it, too. The override mechanism is manually editing the citation.

    Not sure what's going on with the parentheses. The code is designed to handle nested parentheses, which are clearly not at play here. @fbennett will need to take a look, but realistically this won't happen super quickly, so you should find a workaround whether that's rephrasing or manually editing (I'd do the latter)
  • Here is a work around for the capitalisation: I can add a zero-width-space after the period, and Zotero will not capitalise.

    Perhaps one for the tipps and tricks?

    BTW I looked at past discussions of this and it seems that the opinion by users is overwhelmingly against this particular capitalisation, while the developers disagree. Go figure. It has to do with the fact that developers would prefer one to use the prefix field to make the whole footnote a Zotero field, which in reality doesn't work well so one doesn't.
Sign In or Register to comment.