Google Docs errors: Document is locked and "docID is not defined"

edited October 25, 2018
First of all, THANK YOU for the great work on the Google Docs integration. Although it's a bit slow, this is such amazing work by the Zotero developers!

Unfortunately, I started receiving the following error: "The document citations are being edited by another Zotero user. Please try again later" and I can no longer edit or add anything. No one else is editing and I have rebooted my browser, upgraded my browser (latest version of Chrome), have rebooted my Mac, and have waited for over an hour but unfortunately none of this worked.

Next, I tried clicking the "Need help?" button which gave me the option to "to override the document lock?" but when I indicated that I wanted to override the lock I received the following error: "Zotero experienced an error updating your document.
docID is not defined" so I am not sure what is going on.
  • Thanks for reporting. We will have a fix out soon that will make the lock override work. Do you have any idea how the document got to this state in the first place? Do you have many citations in the document? Did you get any errors from the integration before you started seeing this?
  • Hi, thanks for getting back!

    These might be a few related issues:
    1) I have about 300 citations
    2) my co-author manually adjusted a few Zotero citations without using Zotero
    3) when I refreshed the document I received some errors (not related to the edits in point 2 - and unfortunately I don't remember those errors but they 'crashed' the refresh process as I remember)

    Hope that helps and looking forward to the fix.
  • edited October 26, 2018
    The fix is now out with the Connector version 5.0.49. Make sure you refresh the google docs page after updating.
  • Excellent, thanks so much for the quick fix! It works!
  • PS: The update also seems to render Zotero fields in Google Docs in a grey color which is super useful!
  • The fields are grey to indicate that they have been inserted with automatic citation updates disabled and are not in their final form. They will go white once you refresh the document.
  • Hello guys,

    Im having a similar problems. Im using zotero 5.0.55 with google chrome 69.0.3497.100 64 bits and zotero conector 5.0.49 on windows 10 on a portable pc.

    I started using the beta zotero version to try out the google docs integration with firefox a few months a go in a document from scratch. As it didnt came up with any issues, I started using it with chrome as it came with the stable version. Although I dont believe this is an issue, at work I use a pc with different stuff, windows 7, the Chrome takes longer gaps to update.

    I have no more the 100 citations. I have collaborators for this document but none of them use zotero and neither they are familiar with bibliography management. Im not using automatic update.

    It was working fine up to a week or two a go then the following error is coming when I press refresh:

    "The document citations are being edited by another Zotero user. Please try again later."

    When I press "Help"...

    "Zotero locks your document to prevent multiple users from editing citations at the same time. Concurrent citation editing in the document may lead to citation or document corruption. Certain unforeseeable circumstances, such as network failures, may lead to your document becoming permanently locked. If you believe this has happened, you can override the lock."

    Then I press "unlock"

    "Zotero found the following error when updating your document.

    Too many changes applied before saving document. Please save changes in smaller batches using Document.saveAndClose(), then reopen the document with Document.openById()."

    Have no idea what it means. But Im convinced that none else is editing the document when I try to refresh.

    Any tip in what should I do?
  • Probably won't solve the issue, but you should update to Zotero 5.0.57 nevertheless.
  • Would you be willing to share a copy of the document with Zotero developers for debugging purposes? If so, could you make a copy and email an editable link of the document to

    We've had one other report of this problem, but we cannot reproduce it ourselves and are not sure what is causing it. If you cannot share a copy of this document with us, you should make a copy of the document and try 2 things:

    1. Remove chunks of the document from the end of it and see whether the integration starts working again.
    2. Go into the document version history (File -> Version History) and try to find the last version of the document that worked. Then copy the changed contents of the document from your copy and see whether the integration will get stuck again. Note that if you do this, Zotero citations that you copy from the document in the broken state, which do not existing in the older working revision will not work and be treated as simple text by Zotero and will need to be reinserted.
  • Shared the link of a copy through email as requested.
  • +1 from me. When try to unlink, I get "The document citations are being edited by another Zotero user. Please try again later". When I try to override, I get the blue progress bar for a couple of minutes and then the "too many changes applied" error.
  • @pedrobrasil Have you tried working with the copy of the document? I have just tested inserting in a copy of your document and the lock override and further inserting seems to work.
  • edited November 6, 2018
    Im not sure if you are testing in the same document that I can see or a copy of it that I can't see. Looking at the document that I shared and I can see, I can't find what exactly what you changed. If you just inserted a new citation then I must say that I could do that too in first place. For me, the issue remains. When I press "refresh" at the zotero's menu the erros described above pop up. When I try to insert a new bibliography, the edit bibliography window pops up, I click "ok", then after a while the error comes:

    "Too many changes applied before saving document. Please save changes in smaller batches using Document.saveAndClose(), then reopen the document with Document.openById()."
  • @pedrobrasil Sorry for taking a while to respond. Thanks for sharing the document, that helped identify the problem. We have a fix coming for this soon.
  • edited November 13, 2018
    @pedrobrasil We have published the fix for the Zotero Connector beta for Firefox. You will be prompted to authenticate Zotero with your Google Account and might get a scary screen saying the app is unverified. We are in the process of verifying the Beta version of the Google docs addon with Google, so you should click "Advanced" in the bottom of that screen and click "Go to (unsafe)", then finish the authentication procedure normally.

    Also note that the first refresh of your document is likely to be very slow (up to 1hr), but with the fix subsequent updates of the document will be much faster (a couple of minutes).
  • I'm experiencing this problem again... Neither the doc nor my citation folder is shared with anyone and this error message appears:

    The document citations are being edited by another Zotero user. Please try again later.

    I'm running GDocs in Chrome 88.0.4324.192 on a Mac and Zotero Version
  • The prompt allows you to override the lock as well as specify that it can become locked by accident. Do you still get the problem if you override the lock? If not you should not worry about it.
  • I'm also getting this error (another user is edited), I have the option of over-riding the lock, when I do I can choose a citation to add, but then it just hangs on the blue/red progress bar. I need to quit Zotero to get back to my doc.

    I'm running an updated Chrome Version 89.0.4389.90 (Official Build) (x86_64) on Mac and Zotero
  • Depending on the size of the document the update might take a while. If it works fine in a new document you should give Zotero time to work.
Sign In or Register to comment.