Strange browser screen artifact after Google Doc plugin authenticated

I happily discovered the Zotero button in my Google Doc today. Initially clicking on the button did nothing. After restarting both Zotero and Firefox I got to the authentication step and completed it. Then, still, nothing happens after clicking on it. Worse, when I change the zoom level within Google Doc, I get a second screen shot of the same document overlaying on the original one with an offset to the lower right. The second one clears out after like 10 seconds.

I don't know if it helps but here is the debug id: D1106899873, D1533369875

If this is going to take a while to troubleshoot, can you tell me how to unauthenticate Zotero with my google account so that I can at least continue to use Google Doc the way I did before? Because that screen artifact really is very scary and annoying.

  • Whatever screen artefacts you are getting are most likely the problem of your browser or google docs itself since Zotero modifies the document editor minimally. You can disable google docs integration in the Connector Preferences -> Advanced, to see whether that makes a difference.

    As for the integration not working, Zotero appears to be trying to display the document preferences dialog for you. Does the integration work for you with either LibreOffice or Word? When you interact with the gdocs integration you should check all Zotero application windows to see whether an integration dialog appeared, but is hidden behind other windows.
  • After I disabled google docs integration in the Preferences (which I discovered after posting) and closed all my browser windows to refresh, I did see the "smart" dialog box buried behind Firefox. I have yet to enable google docs integration again to see if it works.

    On the other hand, the screen artifact did go away after the google docs integration was disabled. However minimally Zotero modifies the document editor, I believe it is the cause. This happened in Firefox, possibly the latest version. I have not tried it in Chrome it.
  • Does the screen artefact reappears if you enable the integration again? If so, could you post some screenshots and your Firefox version number?

    The document preferences and citation dialog windows should appear in front of other windows, when you first interact with the integration menu options, and would go behind other windows, if you interact with them. You can get back to the citation interface by looking for the dialogs under one of the Zotero windows.
  • I am happy to report it all works now! (Creepy...) Once I know to look for the citation dialog box behind browser windows, it all went smoothly from there. There is also no more screen artifact; I tried in Firefox both general free Gmail account and business G-suite (the one with which I experienced the problem earlier). Thanks.
  • edited October 29, 2018
    Ah, I spoke too soon - the artifact occurred again, but now I know what specifically contributed to it. It appears that when the Google Doc has a table pasted into it, the artifact occurs for a few seconds when zoom level is changed away from default using Google Docs' native Zoom tool. I've tested that both making the zoom level above 100% and below 100% will cause the artifact. I am not sure if the source of the table matters but mine was created in Google Slides. I am running Firefox 63.0 (64-bit).

    Here's the screenshot

  • It almost certainly will, but can you confirm that that still happens if you temporarily disable Google Docs Integration from the Advanced pane of the Zotero Connector preferences and reload Google Docs (such that the Zotero menu disappears)? If it does, this isn't caused by Zotero.
  • I did the test described by you and, yes, the artifact still occurred when Google Docs Integration was temporarily disabled and the Zotero menu was not present. It only went away after I cleared the cache. However, that never happened before the Google Docs Integration was introduced and enabled in the Zotero connector, so I think it's fair to say it's at least an interaction between Zotero and Google Doc.

    For what it's worth, I've now replicated the problems on two different machines, though both running Firefox 63.0 (64-bit) and Windows 7.
  • I think it's fair to say it's at least an interaction between Zotero and Google Doc.
    Can you reproduce it in a new document that you haven't used with Zotero?
Sign In or Register to comment.