RTF/ODF-scan broken in last few days (as of 21 Oct 2018)?

Suddenly (!?) RTF/ODF-scan no longer working. Using zotero standalone 5.0.56, ODF-scan v2.0.37 final. Shows up OK under Tools|Add-ons|extensions with no indication of any problem. But Tools menu show only the "classic" RTF scan: running it produces (at best) RTF out. Reinstalling RTF/OIDF scan, restarting zotero does not help. Also reinstalled libreoffice add-in: mo difference.

Tried going back to next previous ODF-scan version: no difference.

Any other suggestions appreciated. Up against a deadline where I really need this to work, if at all possible...
«1
  • The 5.0.56 update to Zotero temporarily broke the ODF scan plugin. The plugin developers are working on a fix. For now, if you need to run ODF scan to finish a manuscript, you can install Zotero 5.0.55 to get ODF scan working. Download links for this older version of Zotero are listed here: https://forums.zotero.org/discussion/comment/318644/#Comment_318644

    @dstillman Could we pin this thread? There have been a few questions about this over the past week.
  • OK thanks for quick response: will try rolloing back zotero now...
  • Yep, rollback to zotero 5.0.55 gets RTF/ODF scan working again for me. Much appreciated.
  • (I've submitted a fix to the RTF/ODF-scan developers that restores the menu item with 5.0.56.)
  • Thanks dstillman!
  • Unfortunately, it still does not work on macOS Mojave. I have Zotero 5.0.57 and RTF/ODF Scan 2.0.37.
  • Correct — the fix hasn't been merged, as you can see on the linked ticket. The person who releases updates to this extension hasn't been around lately, and I'm not sure when he'll be available or if anyone else has access to put out releases.
  • Yes, apologies for this. I've been in touch with Frank, who currently is the only person who can put out releases and he has promised to get to this soon (and also give me access to do so going forward).
  • or if anyone else has access to put out releases.
    I should be able to, but I'm not sure how to create the xpi file.
  • I concur. Does not work on macOS Mojave. Nor was it working before the update despite a great debut. How reliable is Zotero? I am new to it and would rather not waste my time if problems recur regularly.
  • @olymisan: What? This thread is about a third-party plugin for Zotero that provides an advanced workflow for using Zotero with unsupported word processors. It broke in a recent update, and the developers haven't yet updated it. As you can above, it's being worked on. This has no bearing on the reliability of Zotero itself.
  • @olymisan - do you mean to post this here? Doesn't sound like you're talking about the same issue.
  • Hi, I've tried downloading the plugin but it is not compatible with Firefox v.63.0 currently running on my Mac. Bummer. I've been wanting to use Scrivener to write my doctoral thesis but unless I can get the whole process running via LibreOffice I'll have to stick to Word! Can anyone help? thanks.
  • @Michela_O -- you'd need to install into Zotero, not Firefox. I've removed the instructions for Firefox from https://zotero-odf-scan.github.io/zotero-odf-scan/ to make this clear. But note that as this thread indicates, the add-on doesn't work with the current version of Zotero, so probably not the best time to try it out, even though we should have that fixed shortly.
  • Thank you @adamsmith ! I guess I'll have to wait :)
  • I have a Masters thesis to format, hundreds of citations that need to be converted from Scannable Cite in Word. I have never done this before and have been reading all the instructions. I have updated to Zotero 5.0.57, checked that I have the RTF/ODF extension, and both the Microsoft and Libre Office plugins. No matter what I do I can't get an RTF/ODF Scan to show in my Zotero Tools. Only RTF Scan. Is there anything more I can do?
  • See above -- the add-on doesn't work with current versions of Zotero. If you're in a rush, downgrade Zotero temporarily. Otherwise, wait until it's fixed.
  • How do I downgrade Zotero?
  • Download links for the old versions are linked to above: https://forums.zotero.org/discussion/comment/318644/#Comment_318644
  • @debhurn Dito. It worked for me, but since Mojave on Mac the menu item is gone. I guess we'll have to wait. Try finding another pc of a friend or so on which you can install Zotero to convert your thesis.
    My thesis is due in December so I hope it'll be fixed by then... Good luck!
  • @JAPple: No, this doesn't have anything to do with Mojave. As explained above, the plugin just doesn't yet work with Zotero 5.0.56 and later, so you'd need to restore to Zotero 5.0.55 if you want to use the plugin.
  • OK, with apologies for the delay, I've just released version 2.0.39, which has dstillman's fix and worked in a quick test.

    I think automatic update should work, but if it doesn't, you can manually update by reinstalling from https://github.com/Juris-M/zotero-odf-scan-plugin/releases

    Note that this does _not_ fix the failure to automatically install the Scannable Cite translator. I'll see if we can fix that for the next release, but until then new installations will need to manually downlod the file from https://github.com/Juris-M/zotero-odf-scan-plugin/raw/master/resource/translators/Scannable Cite.js , place it in Zotero's translator directory, and restart Zotero.
  • @adamsmith Fantastic! Thank you for looking after the issue so promptly!
  • edited 8 days ago
    Doesn't seem to work for us. Doesn't recognize any items in the scan
    UPD - this is confirmed by 2 people on our team on 3 different (Windows) computers and one Linux distro. We do seem to get success with Zotero 0.55, the 2.0.35 final plugin AND (for some reason) an older version of LibreOffice (6.0.7 win64)
  • It works for me, including with the document you sent, but I'd also need a more specific error report that "doesn't recognize any items in the scan" -- as always with errors, steps to reproduce are needed.
  • @adamsmith I've looked at the translator installer code and it looks almost the same as BBTs code, except I have the initial "Zotero.Translators.init()" replaced with "Zotero.Schema.schemaUpdatePromise". I'd test the ODF scan plugin with that change but I don't know how to build it; build.sh doesn't work for me as "jm-sh" is empty.
  • Would you mind making a quick PR? I'll build and test
  • (@emilianoeheyns: It’s a submodule. You have to do a recursive clone.)
  • Still can't build because I'm missing api_key.txt and secret.txt, but I've submitted an (untested!) PR.
Sign In or Register to comment.