Need to add a full stop after "p" in citations that include page number?

Hey everyone!
Is there any way to add a full stop after p?
I'd like to have p. XX instead of p XX.
Thanks in advance
  • edited October 18, 2018
    Yes. Certainly. It sounds like the strip-periods is set to true on the label variable="page". By default it should be shown as p. or pp.

    (Hard to tell without seeing your code though. If you want to share it, upload it to Hastebin and share a link with us here.)
  • Thank you for your answer. I am not sure how to find my code. Could you please help me with that?
  • which citation style are you using ?
    (I think damnation assumed this was a customized citation style)
  • American Psychological Association 6th edition
  • The default APA style in Zotero does have a full stop after the p. What exactly are you entering into the page field? And are you talking about an in-text citation page number or the pages for a book chapter in the bibliography?
  • I'm talking about in-text citations. In the page field I just enter the number. I forgot to mention that the full stop is missing when I choose Greek in the documents preferences
  • Okay, just to be sure, the full stop is there if you set English as your language?
  • so you're saying that
    σ. and σσ. would be correct, right? We can fix this, but the fill will wait to the next Zotero version. You can fix it by adding

    <locale xml:lang="el">
    <term name="page" form="short">

    towards the top of the style right after the last </locale> tag.

    General instructions here:
  • Yes, σ. and σσ. are correct.

    Thank you for the code, I'll try to fix it!
  • If this doesn't work for you, the fix is also now in the next version of Zotero, which will be 5.0.57 (can't tell you when that will be released, though)
  • The updated Greek locale is now available in the latest Zotero beta.
  • Thank both of you. Since I'm still learning how to use Zotero, I'll stick to 5.0.56 till the release version is out.
Sign In or Register to comment.