Supress title where no author

After a bit of a search I've not come up with

I have a few references where there is no author and I'd like to suppress the title as I already use the title in text.

Eg. "the Vienna Convention on the Law of Treaties (1969)".

In this instance using 'suppress author' doesn't appear to work.

I'm using the Uni South Australia 2013 style though I've also tested a bunch of others: UniSA 2017, Chicago author-date, Elsevier Harvard, etc.

The only thing I've been able to find on this is the below, which suggests it may once have been a bug. Is this the case, or do I need to format these citations manually?

https://forums.zotero.org/discussion/41614/suppress-author-and-titles
  • This should just work. “Vienna Convention” is in the title field, correct? Can you export this item to Zotero RDF, paste to hastebin.com, and link here?
  • edited October 27, 2018
    Yep, Vienna Convention is in the title.

    It's a pretty simple record: title, publisher, date, url.

    Zotero RDF for it below:

    https://hastebin.com/evugafaxeb.xml

    Here's another example, this one has a few more fields, including contributor, but the result is the same. Title used in in-text reference and not suppressed when suppress author is selected.

    https://hastebin.com/kadisunoxu.xml
  • edited November 5, 2018
    Zerobin links expires and Hastebin seems to be up again so I've updated the links in my previous post.

    Anyone have and more ideas on this?
  • One more try, anyone have any input into this? @bwiernik
  • Sorry I’ve been swamped with work the last few weeks. I’ll try to look at this soon.
  • I'm due to submit my PhD thesis in about a week.

    I'd love to do this without having to manually identify and edit each instance where I'd like to suppress a title.

    Anyone able to help?
  • Unfortunately, at the moment, this seems to be an unexpected behavior in the citation processor, and there isn't an immediate fix without input from the citeproc-js developer. One option would be to enter the title of the document as a single-field author instead of a title. Otherwise, manually adjusting these citations (or just ignoring them and leaving them title in the parentheses, which would be my recommendation) is the only option at the moment.

    @fbennett Suppress Author should also suppress the title variable (or any variable) if it is part of a substitute node.
  • Thanks @bwiernik, really appreciate you taking the time to look into this.

    I'll work around this using one of your suggestions. Given there's not many of them manually adjusting or ignoring them are both options.

    I'd rather not use a single author field as it means putting data in the wrong field and I'd also need to ensure there were no instances the same document needed to cited in full.
Sign In or Register to comment.