Zotero stuck to 'loading items' after I stored my DB on pcloud

Hi,

I loaded my database on pCloud last week, and it was working at first: for the first time, I could sync my files between home (ubuntu 18.04) and my office (Windows 7) (before, I had different databases in both places because they stopped syncing as soon as I reached my 100 Mo limit on zotero.org).

However, since yesterday, when I open Zotero at my office, it is stuck on 'loading items'. I tried the DB repair tool (ID 5bbc6e4cb2b57), but it didn't change anything (contrarily to last week where it helped me solve some issues).

What can I do?

Thank you in advance
  • Right, you can't store your database in a cloud storage folder — you'll corrupt it.

    Move it out and try the DB Repair Tool again. If that doesn't help, you'll need to restore from a backup.
  • Thank's dstillman.
    If you are right, then there is a mistake in this website. Because I found pcloud in the list of compatible WebDAV services: https://www.zotero.org/support/kb/webdav_services
    (I didn't precise in my previous message, but I am using webdav.pcloud.com).

    If what you say is confirmed, how should I proceed to store my database? Set up my own server on a raspberry pi ? Using a php hosting service as explained here: http://blog.holz.ca/2011/11/phpzoterowebdav-installation/ ? Choosing another WebDAV service in the list above?
  • The page is correct, but it refers to file syncing via webDAV, not to putting your entire database on a webDAV. So you'd sync your database with Zotero as before (which is unlimited) and then in the sync tab set up file sync via webDAV -- which could be pcloud or anything else.
  • I am not sure how this is different from what I have done.
    These are my settings: https://drive.google.com/open?id=1qP4VXUQofYnvxIYIGxRA6FoOhvRukwaD
    Are they correct?
  • Plus, are you sure the syncing with Zotero is unlimited? Because the reason why I migrated to pcloud is that sync stopped between home and my office since I reached a SQLite DB of 100 Mo.
  • Btw, my .sqlite is NOT on pcloud. I mistakenly said that I loaded my DB on pcloud: I meant my library files (well, I just set the settings as shown above).
  • Syncing your Zotero item data (the title, author, etc. information and notes) is unlimited. Syncing attachment _files_ (PDFs, etc.) is not. For those you would use a WebDAV service or pay for Zotero storage.

    If you haven’t placed the SQLite database in a cloud folder, then setting up WebDAV shouldn’t have any impact at all on loading your Zotero database. Can you click on the Help menu in Zotero and choose the option to restart with Debug Logging enabled, then submit the log and post the ID after you let Zotero be stuck at the loading items screen for a few minutes?
  • Thank you for being so fast to answer!
    The ID is: D1765017552
  • (the settings in your screenshot look correct, yes)
  • edited 13 days ago
    Update: at home (on ubuntu) everything works fine. The issue is only at my office.
  • The DB you upgraded to the DB Repair Tool was quite corrupted. Generally that happens from having the database itself in a cloud storage folder or network share. Perhaps you did that in the past?

    In any case, same as what I say above: you'll need to either use the DB Repair Tool or restore from a backup (which could just removing your local database and syncing down from the online library).

    Note that, if you properly replaced the local file with the repaired version, it wouldn't be corrupted, so either you didn't do that correctly or it got corrupted again after that.
  • Oh I put the repaired DB in the wrong folder that's why *ashamed*.
    Now it works. Hoping my problems will stop here.
    Thank's a lot for your help!
    Suggestion for developers: that Zotero repair DB locally.
  • I still have an error that I had last week:
    'accessDate' must be in ISO 8601 or UTC 'YYYY-MM-DD[ hh-mm-dd]' format or 'CURRENT_TIMESTAMP' (1992-09T1992/09Z)
    It may hinder the sync, I am not sure.
  • When are you seeing this? During syncing? Can you provide a Debug ID for the action that triggers this?
  • edited 11 days ago
    I am seeing this at the end of syncing (don't know if syncing is interrupting for this reason or not).
    D189493513
  • So somehow you ended up with the value "1992-09T1992/09Z" as an access date for a PDF attachment. That's invalid, and very strange, since it shouldn't be possible. I'm not sure how that would've happened.

    Paste KF9MU74T into the search bar in All Fields & Tags to see the attachment in question, delete it, and empty the trash. You can then add back the PDF.

    You only added that attachment a few days ago, so if you recall the steps you took to get that into your library (web import? file import? something else?), that might help us figure out what caused this.
  • Ok, this is the paper in question: Bardhan & Roemer (1992).
    I remember why I imported it: it was to test whether sync was working, after I put my files on webdav.pcloud.com
    I imported it through chrome extension, from this webpage: https://www.aeaweb.org/articles?id=10.1257/jep.6.3.101
    Don't remember on which device I imported it. It may be from an Ubuntu virtual machine at my office's Windows computer. There is an issue with this VM: the time is delayed by 15 min. Maybe that's linked.
Sign In or Register to comment.