Copy Bibliography keyboard shortcut (shift+cmd+C) copies citation (Mac Zotero 5.0.55.1)

edited October 8, 2018
I just noticed this today but would guess it comes from the most recent update to Zotero for Mac (5.0.55.1) from a few weeks ago.

When I use the Edit menu to "Copy Citation" or "Copy Bibliography" both work correctly. But from the keyboard both shift+cmd+A and shift+cmd+C give me just the citation. I can't seem to copy the full reference in bibliography format from the keyboard.

--

Edit: OK, this is bizarre behavior.

The keyboard comments function differently based on whether one item or multiple items are selected.

Multiple items: the commands work as expected.

Single items: only the last-used command for multiple items works.

In other words, if I select two entries in Zotero, then press shift+cmd+C, a bibliography containing both items is copied, and from that point forward if I select only one item, either shift+cmd+A or shift+cmd+C will copy only the bibliography for that item, never the citation. And the other way around, if I select multiple items and press shift+cmd+A, then it gets stuck as copy citation for any single items for both shift+cmd+A and shift+cmd+C.

This explains why I just found the bug: I very rarely use shift+cmd+A, and must have clicked it by accident at some point (possibly a while ago), and set it to citation only for single items now. This also means I can just 'reset' it to copy bibliographies for now, and it'll work for me. But something strange is going on with the code here :)
  • This works fine for me. Can you provide a Debug ID for Cmd-Shift-C producing a citation?
  • edited October 8, 2018
    @dstillman, did you see my just-discovered edit? Try that again with the weird complication. If it still doesn't work, yes I'll provide the debug info.

    --

    Edit: Huh!

    I just tried again to log the debug, and now it seems to be working. I swear it wasn't five minutes ago. Maybe it got fully reset when trying with multiple items? I wish I'd had debug logging turned out when it wasn't working...

    I guess this is 'resolved' in the sense that it's not "broken" right now and if it happens again I can just mess with it for a bit to "fix" it probably. So feel free to close or mark this as resolved, unless the developers want to follow up on this.
  • I've experienced this intermittently but have never been able to reproduce it after a restart.
  • @bwiernik thanks for the confirmation I'm not imagining things! In fact, in this case I did restart Zotero [but not my computer] when it was originally behaving strangely, and it continued to do so until I selected multiple items and somehow managed to reset it that way as described above.
    I'll just restart or otherwise reset it next time, no big deal, and as long as you're aware of it then this discussion has served its purpose.
  • If you are able to reproduce the bug consistently and can submit an Error Report ID and/or Debug ID, that would be really helpful to the Zotero devs.
  • OK, I will keep an eye out for it and try to submit something if possible.
  • edited June 21, 2019
    I think this has increased recently with the last few updates. It often seems to default to copying the citation rather than the bibliography when I press shift+cmd+C. It also no longer seems to alternate as described above. It does sometimes still copy the bibliography, but not reliably. And restarting Zotero doesn't reset it.

    Just trying it out right now, here's what happened:
    1. Shift+cmd+C copied citation, not bibliography.
    2. Restarted Zotero.
    3. Error continued.
    4. Using the dropdown menu I copied either citation or bibliography. Shift+cmd+C continued to have the same error regardless.
    5. Shift+cmd+A copied the citation.
    6. Now Shift+cmd+C copies the bibliography again. Seems consistent for the moment, and remains consistent after restarting.

    I've noticed this a couple times over the last week. I never intentionally used "copy citation" (instead I use the Word plugin), but I fairly often, usually multiple times per day (often just to test that my entry looks right) use the copy bibliography function from the keyboard shortcut.

    Of course now that I've temporarily "fixed" this I can't provide a Debug ID. Next time I happens I'll try to do that first!!
  • edited July 25, 2019
    It's been working for a while, but just now I happened to notice that shift+cmd+C copied the cite rather than bibliography, so I enabled debug output logging: D158514683

    That's simply pressing shift+cmd+C, then shift+cmd+A, then shift+cmd+C and getting output of (Author YYYY) only for all of that; then I used the mouse to click Edit>Copy Citation, and finally Edit>Copy Bibliography, and both of those worked, with different output. But the keyboard commands still don't work differently.

    Note: previously when this has happened trying both versions back and forth 'fixed' it so the shortcuts started working again like normal, not clear why it's not happening now.

    Edit: restarting Zotero resets this, still unclear what triggers it.
Sign In or Register to comment.