Speeding up the Primo fix


The incompatibilities between Ex Libris' Primo and Zotero translator is getting frustrating. The start of the academic year is not a good time for this to fail as new students look around at reference management options. At my institution - University of York - they will see Paperpile working smoothly with the catalogue but Zotero failing.

Is there any way I / we can help to speed up a resolution? IS it Ex Libris or Zotero?

I have the support of our library staff but as I understand it the only Ex Libris issue relating to this ( https://ideas.exlibrisgroup.com/forums/308176-primo/suggestions/31362322-make-zotero-work-with-primo ) is closed.

  • edited October 2, 2018
    We're fairly certain it's ExLibris. The message quoted here: https://forums.zotero.org/discussion/comment/316205/#Comment_316205 suggests they agree and that there is a ticket, but it doesn't hurt to have other libraries enquire as well (edit: I don't think the message you left on that ticket is helpful as the ticket actually refers to the new UI, where Zotero _is_ working). Note that you can use standard RIS export from Primo to import into Zotero.
  • Hi - re: the Primo issue; the RIS export was working for me a few weeks ago, but now it isn't (for me). Unfortunately, I will have to move to a different reference system soon (well, now) because I am actively using this for writing and I am struggling to keep track of my references. I like Zotero and hope ExLibris can get this fixed quickly so I can move back.
  • Could you just use a different catalog? Seems like much less of a hassle than switching reference manager.
  • Not sure what you mean by that, but I have tried the other options under 'actions' and the libraries I use (universities) seem to have Primo....and I am tired of seeing
    'An error occurred saving with Primo. Attempting to save using Embedded Metadata instead'. The amount of time I've spent trying to ensure that the latest versions of Firefox run with Zotero and now this issue, will be less than just using EndNote which I already have on my computer. I'll check back in a few months to see if the Primo problem is fixed. Thanks
  • Although my primary library doesn't use Primo for its catalog, I work with a volunteer at a Primo library and she can no longer get the results she needs by using Zotero. She, too, says that RIS isn't an option. Other reference management software can capture Primo records without using RIS.

    Please offer a more complete set of instructions on how to get RIS from Primo that will import to Zotero. Better yet, please provide an explanation of why Primo stopped working with Zotero and quell the rumor that Primo is intentionally blocking Zotero users.
  • RIS -- Primo instances differ, but e.g. for York, where Richard is, if you look at a record like http://yorsearch.york.ac.uk/44YORK:44YORK_ALMA_DS21215975420001381
    you'd click on send to --> RIS (Endnote, etc.) and then open the downloaded file.

    As for rumors, I don't know what sorts of people you talk to, but they're clearly not good sources of information; this is now the second completely unfounded rumor you bring up here. It's rare that a site would specifically go out and try to block Zotero and if I suspect that might be the case I will just say so and say so loudly, both here and on Twitter, no need to speculate. For Primo, the opposite is the case: Ex Libris reached out and worked with Philip and me, including implementing dedicated code, to make their new generation of catalogs work with Zotero (those are the Primo catalogs that have primo-explore in the URL).

    Zotero import from Primo stopped working for the old-style Primo catalogs because the way Zotero accessed Primo metadata (PNX) no longer works. My understanding is that this is a bug at ExLibris introduced in a recent update, but that's all I have on this and I don't see a reasonable way for Zotero to import without this. This is all covered in the thread I link to above.
  • edited October 19, 2018
    I bring up rumors that I hear in library (and some other) circles so that they can be reasonable squashed. It isn't as though something like this rises to the level of something to be mentioned on Snopes. There are likely to be other rumors. Mentioning falsities here seems a good way to let informed people disprove them. I can say, "That doesn't make sense. Why would ___ harm themselves as a way to harm Zotero." But conspiracists often need more specifics than I can offer to deny their false reality.

    edit: I don't have the imagination to just make these silly things up.
  • For information:

    I have been able to use the "save to Zotero" bookmarklet with York's catalogue as an alternative to the usual Zotero Connector until this morning (2018-10-21). Now that just creates a generic "Yorsearch" entry.

    I don't recall installing a Zotero update recently so possibly York's instance of Primo has had a tweak, but unfortunately not a fix!

    The Zotero Connector still does not work.

    Best regards,
  • I've just realised that the problem with the bookmarklet is probably due to a Chrome update rather than Zotero or Primo. I'm on Version 70.0.3538.67 (Official Build) (64-bit).
  • edited October 21, 2018
    @richard.masters: That was actually the hint we needed, and this is now fixed. (If we knew it was working in the bookmarklet, we could've fixed this sooner. The bookmarklet should never be more functional than the Connector.)

    We did in fact update the bookmarklet yesterday to bring it in line with current Zotero Connector code. We made a change to the Connector in 5.0.41, released on September 4th, that made sure we displayed an error message in the save popup when a web request failed (instead of showing a blank box), but the Primo translator was relying on old behavior in which 404s were ignored so that other requests could be attempted. I've pushed version 5.0.43 of the Connector and a new version of the Primo translator that, together, should fix this. I've also pushed a new version of the bookmarklet.

    Your Zotero Connector should auto-update within 24 hours, or you can 1) update extensions in your browser's extension pane and 2) click Update Translators in the Advanced pane of the Connector preferences with Zotero open.
  • Sorry about this, that's clearly on me. I was aware of the connector change and I think Richard had actually mentioned using this with the bookmarklet somewhere, so I took what I thought was a pretty close look at what was happening outside of Zotero and encountered the same issue in accessing the PNX and only at that point put this on ExLibris. I must have done something wrong in constructing the PNX urls (sachaj in the other thread found the same thing I did). Anyway, clearly this would have gotten fixed more quickly had I not misdiagnosed, so apologies for that.
  • HI @dstillman @adamsmith
    Hey, that's good to hear! One of the things I love about this community (apart from delivering a superb reference manager) is the open spirit with which support is carried out.

    I have just checked the connector in Chrome and it is still not working for me, but the 'Save to Zotero' bookmarklet is.

    I removed the Zotero connector extension in Chrome and added it again - it is showing 5.0.43. I updated translators as well (with Zotero open) just to be sure. I then restarted Chrome. But it still fails to save the book metadata.

    For example, with this record:
    it is saving the web page with snapshot.

    Can I do anything to test further?

  • @richard.masters: Try updating translators in the Advanced pane of the Zotero preferences and then updating again in the Zotero Connector preferences.
  • @danstillman : I just tried that but it still isn't working.
  • It shouldn't be necessary, but you can try resetting translators in both the Advanced → Files and Folders pane of the Zotero preferences and in the Zotero Connector.
  • Does the above URL (or anything on York) work for you @dstillman? I'm definitely using the new translator and the 4.0.43 Connector and no luck.
    Submitted Debug for loading the (resolved) URL Richard posted above and trying to import D1777690064

    (Also no luck on the other Primo classics, so this isn't York specific)
  • Oops, sorry about that. Try again in 5.0.44.
  • Hi @dstillman @adamsmith
    Connector on 5.0.44 and translators updated and it is working again with York and British Library.
    Connector and bookmarklet appear to have identical behaviour.
    Many thanks,
  • edited November 2, 2018
    I was happy to see a resolution to this problem, but I guess our Primo is setup differently than York's? I am able to save from York's interface, but not ours. Example : http://decouverte.uquebec.ca/UQTR:UQTRPLUS:aleph_udq000685649
    The connector can see it's a book, but end up saving as a webpage.
    (updated everything and reset the translators in connector as well as in Zotero)
  • @richard.masters Just in case, are you on the August SP?
  • Did this use to work? All other catalogs with reported issues are working again now.
  • edited November 2, 2018
    It used to work, yes. In my Zotero library I have an item saved from Primo June 2018 (don't think I've tried much during the summer)
  • Thanks -- I'll try to see if I can spot what's different over the weekend
  • edited November 2, 2018
    Our public interface is one minor update behind latest update, but our test interface uses the lastest Ex Libris update available, and we have the same problem there : http://decouvertetest.uquebec.ca/ENAP:ENAPPLUS:aleph_udq000289058
Sign In or Register to comment.