Zotero crashing Nvidia display driver, leading to blue screen

Hi, since last Nvidia display update I've twice had an instance where opening Zotero causes the display driver to repeatedly crash, if I minimise the Zotero window it stops, if I leave it open it blue screens after a few seconds. It doesn't happen every time (after blue screen restart it seems to open ok).

System is otherwise stable. I did have a problem with Nvidia display driver crashing with applications like Firefox, Zotero and Excel a few months back, but that was a well recognised problem that was ultimately fixed by Nvidia. No idea if this is related to that, but only seems to be affecting Zotero.

This is on Windows 7, both Zotero and Nvidia have latest patches.
  • @dstillman and other developers

    It seems, Zotero has some issues incompatible with NVIDIA drivers.
    At 05 June 2020 my Zotero starts without any problem.

    But today it is not starting. I have got permanent Zotero Startup error. That error could not be debugged (at least by me) because Zotero window is not responding. I tried all Startup Recommendations from Forum (From Run Line with -ZoteroDebug and -jsconsole options). Even jsconsole window was not responding.
    Then I have uninstalled all the programs and updates since date of last successful Zotero Startup (05 June 2020) -nothing helps

    I have uninstalled Zotero with the help of REVO Uninstaller.
    Then reinstalled it - nothing.

    Fortunately, I had 5.0.17 installer and I installed that old version. It doesn't start, but it could start with -jsconsole option.
    No any errors were notified.
    Since I have deleted (moved) all user files from default location it asks about different option - find old location or create new one.
    I've created new one - it starts
    And the starts anytime.

    After updating to new version - doesn't start
    Occasionally I clicked by right mouse button on the Zotero icon and see option "Run with graphics processor".
    I use it on my laptop where Integrated Intel Graphics and High-Performance NVidia Processor present. I've remembered that a week ago I've changed my default graphics processor to NVIDIA because I've bought new external monitor and tried different mode of the performance.
    So, I selected integrated graphics and Zotero started up

    Maybe this information will be helpful to anybody.
    At least, I think the Developers could add checking the NVIDIA processors presence and provide warning to users with this issue.

  • I have recently begun to experience a similar issue with Zotero, causing sporadic BSOD.

    It appears to be an issue with NVIDIA drivers or graphics (as mentioned above), as loading the programs causes my display to flicker with a black sceen before the ultimate BSOD.

    Any advice or updates planned?

Sign In or Register to comment.