[SOLVED] Problems with "undo" in Zotero+LibreOffice

edited September 17, 2018
Whenever I use Zotero in my word processor, somehow I completely lose the option to "undo" changes... I can even see the "undo list" up to the moment I inserted the 1st citation... it's like after that the changes are not recorded by the "undo monitor" (just to use a name, I lack the proper terminology).. Is this a problem of the word processor? or Zotero? Is there a way to avoid this? I want my "undo" capability back :)

I'm running Zotero 5.0.55 on LibreOffice 6.0.11, on Linux 64-bit.
  • edited September 13, 2018
    [Removed after correction.]
  • That’s not really accurate. In LibreOffice, you can use undo normally with Zotero—all Zotero changes will be undone at once. In Word for Windows, the same. Word for Mac doesn’t let add-ins package their actions together into one step the same way, so you will see several undo Zotero actions if you look at the undo list. You can safely use undo by bringing up the undo list and selecting all of the Zotero actions as a block.
  • Thank you for correcting me, bwiernik. I use Word for Mac. I will remove what I wrote above to avoid confusion. I'm not sure what the issue is then for LibreOffice that the OP was asking about!
  • @DO_part73 What exactly do you mean? What do you see when you open the undo list after doing a Zotero action?
  • @DO_part73 You should go into Zotero Preferences -> Cite -> Word Processors and reinstall the Zotero plugin, then restart LibreOffice. We had released an earlier version of the LO plugin that had the bug you're describing, but it's since been fixed.
  • @bwiernik @adomasven Thanks, I have been trying different things and I guess there is something wrong with either my specific case. I can't tell if the culprit is Zotero or Libreoffice though.
    The "undo" problem seems anecdotal... now when I want to edit (and sometimes when trying to add) a citation, LibreOffice get's kind of unresponsive. I say "kind of" because I can move around the window, minimize, etc. but can't do anything (click anywhere doesn't seem to do anything -same happens with keyboard). And it is kind of "serious" because it is not enough with killing the application, I have to actually restart the PC.

    Is there any information I could provide to investigate if the problem comes from Zotero or from Libreoffice?
  • I edited the title (it wasn't fair)... until I can confirm what the problem is.
  • @adomasven THANKS! Reinstalling the add-on did the trick. Not only that, but LibreOffice (and maybe Zotero as well) seem to start much faster!!! The add on I have now is 5.0.14, while Zotero is 5.0.55, is that OK, shouldn't the version numbers match?

    Thanks again. I love Zotero!
  • edited September 17, 2018
    @bwiernik what I see in the "undo list" now (every time I add/edit citations or add bibliography) is just a "Zotero action", so I can undo and redo only that step... as it should be, so everything's working fine here!
  • Great. 5.0.14 is correct for the LibreOffice Add-in. The different numbers are a legacy of when Zotero for Firefox existed. The add-in will automatically update with Zotero.
  • I'm quite new to Zotero but I seem to have the same issue as described here. I cannot use the undo button although I'm able to see the list of recent actions.

    I use LibreOffice with Zotero Plugin 5.0.20.SA.5.0.76 (that's what it says in the Addon manager) on Linux.
    I reinstalled the Addon, but didn't seem to make any difference.

    Does anybody know a solution? Much appreciated.
  • What does it say in the LibreOffice extension manager? Is it reproducible strictly after you restart Zotero and LibreOffice and insert a citation in a new document? Could you submit a Report ID?
  • I haven't been able to reproduce the error, although I'm certain that last time a restart didn't solve the problem.
    Will report back if it happens again. Thanks for your reply
  • Zotero Error Report 1181562428

    I'm experiencing the same problem. I'm running Zotero Standalone 5.0.77, LibreOffice, and the LibreOffice Integration 5.0.20 on a Ubuntu 18.04 system.

    I tried to reproduce the error in other documents with "random" results. When the error occurs it does so after inserting a new citation. I am still able to see the list of actions that could in theory be undone but the undo button is greyed out and selecting items on the undo list does nothing. "Zotero Action" is "stuck" on top of the list.

    I reinstalled the LibreOffice integration but it didn't help fix the problem.
  • Did you get an error from the Zotero plugin when the Undo got stuck? After restarting LibreOffice is there a reliable way to reproduce this?
  • No error from the Zotero plugin and no reliable way to reproduce it, but the problem may be solved. Literally a minute after posting here LibreOffice updated from to and the error has not reoccurred since.
  • I have the same problem but I know how to reproduce the problem and also how to avoid it. I am on Zotero 5.0.80 with LibreOffice
    The problem happens when you try to add a citation when you have not open yet Zotero standalone. Then you may open zotero and put the citations on the document but the undo gets frozen, and it becomes impossible to undo even with "Ctrl. z".
    If you save the file and reopen it when Zotero is already running everything works just fine.
  • @pabloredondocrespo Thanks for reporting this. We were actually looking for a way to reproduce this reliably and a fix will be included in the next update of Zotero.
Sign In or Register to comment.