Failure to sync?


So I've been using Zotero for the past year and I really like it, been very good at keeping all the articles I'm reading organized to some extent.

However, recently I had to purchase a new laptop and reinstall Zotero. I've confirmed all the settings are the same with all the same add-ons as well, but while the PDFs are still in exactly the same place on both machines, on the new machine (Computer B) many of the files are lost. By "lost" I mean that when I double click in Zotero to open the PDF, I get a "The attached file cannot be found" error, with an option to locate. If I locate it, everything seems to work fine afterwards, even when restarting the program.

I followed the steps from here ( and discovered that while Computer A (the old machine) seemed to be uploading, the files never made it to the server. By this I mean I reset the file sync history and then began a sync manually. Took about ten minutes, and all of the little green circles indicating that there's an attachment became little filled green circles, which I believe means that they have been uploaded. However, when I went onto and looked at my library, the same ones that are missing on Computer B are missing on the saved cloud database. Thus, while the names and metadata seemed to be syncing fine, the PDFs themselves were mostly being ignored.

One other thing of note: when I manually locate a "missing" PDF on Computer B and then start a sync, the PDF is still not uploaded, despite requesting sync of the full text.

I have a Debug ID D2007248254 for the process of resetting the sync history and then trying to sync, but since I've never done one of those before, if another is needed I can provide it.

It's rather odd that I need to sync to the Zotero server to "re-attach" the PDF when the absolute directory address on the machine has not changed at all. It's saved in a Dropbox subdirectory, which is in the same place as well.

Anyway, any help with (a) why the syncing isn't working properly, and (b) any way to just automatically "re-attach" the PDFs, would be much appreciated.

  • This isn’t a sync issue, but rather your path to your Dropbox folder that you’ve linked to is different on the new computer. You can fix this with these steps:

    1. Install the Zutilo plugin and use it to batch edit the attachment file paths to point at the correct Dropbox folder on the new computer.

    2. In the Advanced pane of Zotero preferences, set the “base directory” to the Dropbox folder holding all of the PDFs. This will convert the linked files in Zotero to be relative to this folder. On other computers, similarly set the base directory to wherever the Dropbox folder is located.
  • That worked wonderfully, thanks! I missed that my username had changed since apparently Windows 10 forces that on you.

    However, I'm still confused about the PDF syncing. Some of the PDFs seem to have been uploaded to the Zotero servers, but most have not. Is there a reason for this?
  • See the distinction here between stored and linked file attachments

    Stored files are uploaded to Zotero servers. Linked files are not.
  • Ah! Fantastic. That clarifies it. Thanks for the help!
Sign In or Register to comment.