[Error report] WebDAV credentials invalid

Hi everyone,
report ID: 525870211.

I am using the newest version of Zotero (5.0.55) on a Surface 1 Pro with Windows 10. I use WebDAV to sync my pdf files. The remote server is under my control. All Zotero installations on my other computers sync to that exact webdav account without problem. I cannot get this Zotero installation to sync to it.
When I enter URL and credentials, it either says that no valid URL was entered, or the credentials are incorrect.
My impression is, that zotero does not use the username and/or password I just entered into the fields. I get this impression from the fact that repeated efforts of entering the URL finally made Zotero accept the URL and it moved on to the credentials issue, which is where I'm stuck now.

I got this surface specifically for the purpose of reading from my library, so it would be amazing if you could provide support on this issue.

  • https://github.com/zotero/zotero/issues/1291

    Should work if you either click twice or just press Enter instead.
  • Thanks for your reply.

    Unfortunately, I cannot get it to work that way. I tried to reset Zotero by deleting the ...\AppData\Zotero\Zotero folder and starting again, but that didn't help either.
  • ...I can confirm that I had to do 'Verify Server' multiple times on my other computers, just as described in the other ticket you linked. Those computers were set up on previous zotero versions.

    Right now, this does not help.
  • edited August 18, 2018
    Don't delete files — that won't help with this. Have you tried simply closing the window and reopening it? Are the values still entered when you do that? You can also press Tab to move out of a field, which should save the value.
  • Yes, I have tried this and I'm using Tab and keyboard only controls.
  • dstillman,
    I am sorry to be using methods that are not supportive of debugging the problem. I found a workaround that seems to be working right now: I removed zotero and downloaded an old version (5.0.40). This version seems to be fine in letting me input webdav credentials. It is currently syncing my library, after which I will upgrade back to 5.0.55.
Sign In or Register to comment.