Collections Disappeared (twice - two separate)

Hi, I am having a strange Zotero issue. I am a longtime user with a very large "My Library" with over one hundred collections and countless subcollections. I have an unlimited storage account online and I run the client on 4 computers. All synch nicely. The problem started last Sunday on Aug 12, 2018. I was doing my usual capturing of web sources into specific folders. Nothing different than normal. On Monday I noticed I was missing an entire Collection and all subcollections. This top-level collection just disappeared. I was certain that I had not deleted it as there is a prompt to accept deleting collections (which is something I rarely do). All my other computers but one had synched. Thak goodness I was able to isolate the one computer with the collection still on it. I made a new top-level collection and then dragged all the sub-collections into the new one. I turned synched back on and then the new collection synched to my other computers. Whew!

I subsequently did a process clearing the data file and re-downloading from the server just to be safe.

All good. But it happened again.

Just moments ago, I started the process of catching up on capturing the web pages that I had left unattended this week. I was using the chrome capture plugin to file pages into my top-level "Education" collection. I created a new sub-collection for "Sex-Ed" and filed several pages into that sub-collection. I then spent half hour filing pages into other top-level collections. I returned to file another page into "Education" and the collection WAS GONE. Poof! I did not delete this I can assure you. So that's two top-level collections that have just vanished within the last 6-days. Again I ran to the laptop and the collection was still there so I dragged all of the sub-collections into another folder and was able to save everything.


I absolutely did not delete. I did not drag the top-level folder into another collection.

It literally just disappeared. In the 6-years of working with Zotero I have never experienced this bug before.

Zotero is my KEY research organizing system. The Top-level and sub-level collection filing method is essential to organizing.

Any help to understand what is going on would be more than appreciated.


  • Opps, apologies it was my "Elections" top-level that disappeared and I saved it by dragging the sub-collections into "Education"
  • edited August 17, 2018
    In your online library you have an "Elections" collection — created last year and updated today — that's currently a few levels below another top-level collection. I'd guess that you simply accidentally dragged it into another collection.

    You can click on a collection, press + on your keyboard to expand all rows, and type "Elections" quickly to focus that collection. (If you get the new one instead, just wait a second and type it again to find the next one.)
  • Hey thanks man, so much for the quick response!!

    In it you state:

    I could not find two instances of "Elections" in the Online Library or in the My Library in my client.

    I was not able to use your tip to < press + on your keyboard to expand all rows, and type "Election" quickly to focus that collection>

    The plus key did not expand the collection. Clicking the toggle or using the left/right keys did. I could not recreate a "quick" search function. However, let me say that I believe a huge feature would be to allow users to search for collections by name. That would be so huge. Is that already available?

    Ok, regarding the disappearing collection problem.

    I went through all of the collections twice and I could not find two instances of my "ELECTIONS" folder.


    *I currently can see only one collection titled "ELECTIONS - NEW"

    *This is the new collection that I created on Thursday to save the sub-collections from the original "ELECTIONS" collection that went missing (on my iMac & Zotero Online)

    *My laptop had not yet synched, so the missing "ELECTIONS" collection and its sub-collections were still there

    *That's when on my laptop I unlinked the Zotero client from my online account

    *I created a new collection titled "ELECTIONS - NEW" and dragged all of the sub-collections from the "ELECTIONS" collection that had gone missing.

    *I reconnected the Zotero client to my account online. Clicked Synch.

    *Online library updated with the "ELECTIONS - NEW" collection/subs and everything synched to my other devices.

    *The original "ELECTIONS" collection disappeared from the laptop client (expected from synch).

    Based on your response it sounds like you may be able to see this original "ELECTIONS" collection.

    Thus, your conclusion I simply dragged the original "ELECTIONS" collection by mistake into another collection.

    Could you tell me the name of that sub-collection where I moved it to? I can't find it.

    Could you confirm the date created and modified for: "ELECTIONS" & "ELECTIONS - NEW"

    I really need to track this down. As mentioned this happened for the first time last Sunday. You can see the results with the Top-level collection titled "PRODUCTION - NEW".

    I this was a mistaken drag, then there should be an original collection titled "PRODUCTION" buried somewhere in a sub-collection. Could you do a search for that please __ Do you see it?

    Could you confirm the date created and modified for: "PRODUCTION" & "PRODUCTION - NEW"

    If we can confirm the original collections still exist, just buried, then I know the problem is on my end (I use a KVM switch and it's possible moving the mouse, while switching computers is causing this).

    But, if we can't find the original "PRODUCTION" or "ELECTIONS" collections buried in the library, then we know this is a Zotero issue. And trouble-shooting that will be tough.

    Thanks again, really appreciate the help with this. Zotero rocks!

This discussion has been closed.