Need Help for Citation Style (Bursa Uludag University/Turkey)

Hi all,

I am working as an information specialist at Bursa Uludag University. We are working on generating citation styles of our institutes. I have encountered some problems. Is there anyone who can help? I can send my CSL files to whom interested.

Best wishes
Özhan
  • Post here with questions; share the style by pasting it to https://hastebin.com/ , click the page with the + sign at the top right, and post the URL here.
  • Hi Adam,

    Thanks for your guide. https://hastebin.com/pesineroto.xml

    I am using for editing http://editor.citationstyles.org/codeEditor/.

    I would like to use ve ark. when citing three authors, the inline citation should be (Saglik ve ark. 2018). ve ark. means et all in Turkish.

    I would like to exclude (Eds.) because we write editors after the book. Is it possible?

    I could not manage the exclude " : " before the publisher and pages.

    Lastly, I would like to exclude the parenthesis of years from a bibliography.

  • I'm not sure I understand all of these. Could you give this in the form of "currently looks like this" -- "I need it to look like this"?
  • Hi Adam,

    Sorry for my late response.

    In the inline citation, currently looks like this: "(Yeluri ve Castro-Leon ve Harmon ve Greene 2012)"

    I need it to look like this: "(Saglik ve ark. 2018)

    "ve" means "and" in Turkish.

    In the bibliography, currently looks like this: "Yeluri, R. … Greene, J. (2012) Building trust and compliance in the cloud for services."

    I need it to look like this: "Yeluri, R. ve ark. (2012) Building trust and compliance in the cloud for services."

    I did solve the other issues but I could not manage to exclude parenthesis of years from a bibliography.

    Currently looks like this: "Franzen, S. (2016) Merging Information Literacy and Evidence-Based Practice in an Undergraduate Health Sciences Curriculum Map Merging Information Literacy and Evidence-Based Practice in an Undergraduate Health Sciences Curriculum Map."

    I need it to look like this: "Franzen, S. 2016. Merging .... "

    Thanks for your concern

    Best wishes

    Özhan



  • Sorry for the delay:
    1. Two steps for the inline citation. First, set et al min to 3 by replacing line 662 with this:
    <citation et-al-min="3" et-al-use-first="1" disambiguate-add-year-suffix="true" disambiguate-add-names="true" disambiguate-add-givenname="true" collapse="year" givenname-disambiguation-rule="primary-name">

    Then set et al to ve ark in Turkish by adding:
    <locale xml:lang="tr">
    <terms>
    <term name="et-al">ve ark</term>
    </terms>
    </locale>

    immediately after line 53.

    2. Remove et-al-use-last for the bibliography and set et-al-use-first to 1 by changing line 675 to <bibliography hanging-indent="true" et-al-min="8" et-al-use-first="1" entry-spacing="0" line-spacing="2">

    3. Remove the parentheses around the data by changing line 693 to <text macro="issued"/> (you may need to adjust prefix/suffix here to get the punctuation the way you want it.
  • Dear Adam,

    Thank you very much. I am very pleased to solve the problem.

    Best wishes

    Özhan
  • we'll review them and communicate on github. May take a little. Once they're accepted there, they will automatically appear on Zotero.
  • Thanks Adam.

    Best wishes

    Özhan
  • Hi Adam,

    We did add our styles to Github, thanks for your precious contribution.

    One of our scholar warned us about using et-al in one style. I did correct it, but I could not solve one thing. In the bibliography it should be : "Campbell JL, Pedersen OK." but it shows Campbell John L., Pedersen Ove K.. How I can correct it?

    Correcting the citation style do I need the fork the project in Github?
    Here is the link: https://github.com/citation-style-language/styles/blob/master/bursa-uludag-universitesi-saglik-bilimleri-enstitusu.csl

    Özhan
  • On the second question, yes, exactly (it's described under 3b here: https://github.com/citation-style-language/styles/blob/master/CONTRIBUTING.md)

    On the first question (without having looked at the code again) you'll want to use initialize="" for the name.
  • Hi Adam,

    Thanks for your response.

    We would like to use Campbell JL, Pedersen OK. But here it is not like that.

    https://postimg.cc/9D1R7f2Q
  • Your looking at names with s in that Screenshot. You want to look at name without s, one level down
  • Hmm, I see. Here is the screenshot of the name area.

    https://postimg.cc/Z0FLr1SC
  • You need to click enable next to the initialize-with window but then leave the actual field blank.
  • It seems very easy, sorry for my unaware, if we need any changes, I will examine all area that I do not think it is related to our requests.

    Thank you very much Adam. We very appreciate it.
Sign In or Register to comment.