LibreOffice ODT to Word DOCX

I am using LO to run the Zotero scan, then I am saving to DOCX and Open in Word. When I try to Switch to Fields and then Switch to BB (citation style) I get this processing error message:

Zotero experienced an error updating your document.

The operation couldn't be completed. (OSStatus error -1728.)

This happens even after I installed the Zotero beta version 5.0.55

Any other things I might do to fix this problem?
  • Try to delete the bibliography at the End of the document before changing styles.
  • I am seeing two grey big brackets around the opening two words of the document; grey brackets appear elsewhere in the document also. These are footnotes; there is no bibliography appended to the end of the document, I think? how would I see if there is a hidden bibliography, if that is the case?
  • Those brackets mean you are using Bookmarks. Try to switch to Fields in the Zotero Document Preferences.
  • Now this message:

    The version of the Zotero LibreOffice Integration component installed within LibreOffice,, or NeoOffice does not appear to match the version installed in Zotero. Please ensure both components are up to date and try again.
    and Zotero just crashed.

    That is a first
  • Switching to Fields did not get rid of the Bookmarks; and the Bookmarks appear in the DOC version, as well! (instead of DOCX). I am running the Microsoft Word for Mac app version 16.15. and the beta Zotero.
  • That is sounding like a bug related to the major update to Word about a year ago. In Zotero, click Tools -> Add-ons. Then uninstall the Word integration plugin and restart Zotero.
  • This refers to -- Report ID: 846551033, and again under this Report ID:276028513

    Reinstalled the add-on for WORD. Restarted Zotero--tried in both 5.0 and using the beta version. When I open the DOCX in Word, the document is still showing grey brackets in random places, and does not convert to the BB style after I select Fields and Bluebook. instead the document displays this weird set of numbers (code)? following one of the citations

    0/0/00 0:00:00 AM0/0/00 0:00:00 AM

    then, the following error appears

    Zotero experienced an error updating your document.

    The operation couldn't be completed. (OSStatus error -1728.) @[insertFieldRaw:document.m:1354]
  • @lisaleine Before proceeding, you should repeat the step of saving the .odt file in LibreOffice with Bookmarks to .docx, then opening the document in Word and seeing if the conversion works now. If it does not, please produce a Debug ID from Zotero:

    1. In the Help menu, go to Debug Output Logging and select Enable.
    2. Attempt to convert a fresh copy of the .docx file in Word and wait for the operation to complete (if it fails, click through any dialogs first).
    3. Before doing anything else, return to Help → Debug Output Logging and click Submit Output, which will disable logging and submit the output to A window should pop up containing a Debug ID. Click “Copy to Clipboard” and paste the Debug ID into this forum thread.
  • Debug ID D567245994
  • When you open the document preferences in Word, do the two options say Fields and Bookmarks, or Reference Marks and Bookmarks?
  • Reference Marks and Bookmarks. I have to Quit Zotero and reopen it to get Fields and Bookmarks.
  • Does the conversion work after you restart Zotero?
  • No, I got this message again:

    Zotero experienced an error updating your document.

    The operation couldn't be completed. (OSStatus error -1728.) @[insertFieldRaw:document.m:1354]
Sign In or Register to comment.