"Saved Search" jumps back to "My Library"

Hi all:

I normally use a "saved search" to work in Zotero (I like to filter out some items). This worked fine for many years. But after the 5.x release, I noticed that the "saved search" jumps back to the "My Library" top-level entry occasionally (often after I save new items to Zotero). This means, I have to click the saved search again.

Is this a known issue?
  • Can you provide exact steps to reproduce?
  • Actually, yeah, the issue here is that, when you save from the connector and a read-only view such as a saved search is selected, it automatically saves to the library root. But now that there's the target selector in the connector save popup, it keeps the selection in Zotero in sync with what's displayed there, which causes the selection to change to the library root.

    I guess one option here would be for the selection in Zotero not to change for the automatic fallback to the root and to only change if you then made a subsequent selection. (So if you chose a different collection, the search would no longer be selected, but if you just let it save to the library root, the search would stay selected.)
  • Version 5.0.54:

    1) Saved search is highlighted
    2) I search for a paper -- search returns no results
    3) I save the paper to zotero
    4) Paper is saved and My Library is highlighted
    5) I have to click the saved search again
  • Hi Dan:

    The solution you outlined sounds good! The reason I use a saved search is that the search results are cleaner. Specifically, when I search in "My Library", the search results also show the pdf files. The saved search that I created shows "only top-level items". Is there a way to show "only top-level items" in the "My Library" view?
  • A "Title, Creator, Year" search (selectable from the drop-down in the search bar) will match only top-level items.
  • Great! That solved this problem! But I think it would still be better that the saved search remains highlighted. Zotero did this for the longest time and many users may have gotten used to this. Thanks for the speedy help!
  • edited August 3, 2018
    I've created a ticket for the selection issue.
Sign In or Register to comment.